Find the answer to your Linux question:
Results 1 to 3 of 3
I have been over and over different pages with instructions on how to install and update my Orinoco classic gold card drivers but with no success in running kismet. When ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    7

    Help please! Orinoco classic gold/slackware10/kismet problem


    I have been over and over different pages with instructions on how to install and update my Orinoco classic gold card drivers but with no success in running kismet.

    When I go to /usr/src/bin and type kismet this is what I get:

    --------------------------------------------------------------------------------------------------------------
    root@laptop:/usr/local/bin# kismet
    Server options: none
    Client options: none
    Starting server...
    Waiting for server to start before startuing UI...
    Will drop privs to kismet (1000) gid 100
    No specific sources given to be enabled, all will be enabled.
    Enabling channel hopping.
    Enabling channel splitting.
    Source 0 (orinocosource): Enabling monitor mode for orinoco source interface eth1 channel 6...
    FATAL: Could not find 'monitor' private ioctl or use the newer style 'mode monitor' command. This typically means that the drivers have not been patched or the correct drivers are being loaded. See the troubleshooting section of the README for more information.
    root@laptop:/usr/local/bin#
    ------------------------------------------------------------------------------------------------------------

    From my research I can tell that my orinoco drivers need to be patched.

    I think this is where I am having the problem.

    I did not install any drivers for my Orinoco card because with running Slackware 10 I noticed I already have pcmcia-cs-3.2.7

    So I visit http://airsnort.shmoo.com/orinocoinfo.html
    and download the pcmcia-cs-3.2.7-orinoco-patch.diff to my /usr/src/linux-2.3.26/drivers/net/wireless

    Then I type #patch -p1 < pcmcia-cs-3.2.7-orinoco-patch.diff (the file I downloaded)
    This is what I get:

    ------------------------------------------------------------------------------------------------------------
    root@laptop:/usr/src/linux-2.4.26/drivers/net/wireless# patch -p1 < pcmcia-cs-3.2.7-orinoco-patch.diff

    patching file hermes.c
    Hunk #1 succeeded at 184 (offset 1 line).
    patching file hermes.h
    patching file orinoco.c
    Hunk #1 FAILED at 458.
    Hunk #6 succeeded at 1816 (offset 1 line).
    Hunk #7 succeeded at 3629 (offset -2 lines).
    Hunk #8 succeeded at 4012 (offset 1 line).
    Hunk #9 succeeded at 4106 with fuzz 2 (offset -2 lines).
    Hunk #10 succeeded at 4364 (offset -3 lines).
    Hunk #11 succeeded at 4576 (offset -2 lines).
    1 out of 11 hunks FAILED -- saving rejects to file orinoco.c.rej
    patching file orinoco.h
    Hunk #1 succeeded at 28 (offset -9 lines).
    Hunk #2 succeeded at 68 with fuzz 1.
    Hunk #3 succeeded at 273 (offset -9 lines).
    root@laptop:/usr/src/linux-2.4.26/drivers/net/wireless#
    -------------------------------------------------------------------------------------------------------------

    I dont like the line "Hunk #1 FAILED at 458" but I tried to run kismet again and I get the same message as the first one above.

    Any help would be great help to me right now. I have looked over every page out there trying to get this to work over the weekend and none have provided me with the instructions I need.

    Here is some more info I hope would provide assistance:

    --------------------------------------------------------------------------------------------------------------
    root@laptop:~# ifconfig -a
    eth0 Link encap:Ethernet HWaddr 00:08:74:9C:F1:46
    inet addr:192.168.0.3 Bcast:192.168.0.255 Mask:255.255.255.0
    UP BROADCAST NOTRAILERS RUNNING PROMISC MULTICAST MTU:1500 Metric:1
    RX packets:8698 errors:0 dropped:0 overruns:0 frame:0
    TX packets:5704 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:10730401 (10.2 Mb) TX bytes:537176 (524.5 Kb)
    Interrupt:11 Base address:0xec80

    eth1 Link encap:Ethernet HWaddr 00:02:2D:BE:FA:2D
    UP BROADCAST RUNNING PROMISC MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:3 Base address:0x100

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:2 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:100 (100.0 b) TX bytes:100 (100.0 b)

    root@laptop:~#
    -------------------------------------------------------------------------------------------------------------
    My LAN card that is built-in on my laptop is the 00:08:74:9C:F1:46
    My Orinoco classic gold wireless card is 00:02:2D:BE:FA:2D

    What am I doing wrong?

    Thank You!

  2. #2
    Just Joined!
    Join Date
    Jul 2004
    Posts
    7
    Okay I fixed my error above. Only to get a new error now.

    Here is what I did to fix it.

    I followed these two websites together while installing my wireless card drivers.

    http://www.michiganwireless.org/tool...aneKismet.html

    http://pcmcia-cs.sourceforge.net/ftp...A-HOWTO-1.html

    I even downloaded and installed the pcmcia-cs-3.2.7 drivers that were already on my system. Just so I did not miss anything.

    Everything installed perfectly and after I did a reboot my wireless card was tested and detected just fine.

    Ill post back if I have trouble fixing this next error.

    FATAL: channel get ioctl failed 95:Operation not supported


    Thanks

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Posts
    7
    okay I fixed this last error I was getting. I would type in /usr/local/bin/ and type #kismet

    I would get this error at the bottom:

    FATAL: channel get ioctl failed 95:Operation not supported


    I noticed that my kismet.conf file in /usr/local/etc said

    source=orinoco,eth1,orinocosource

    My LAN is on my eth1 and my wireless is on eth0

    so i changed it to say eth0 instead.

    now it works

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •