Find the answer to your Linux question:
Results 1 to 5 of 5
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Add Slackware to GRUB

    I've just built a laptop with openSuse 10.3 and Mandriva, using the Mandriva GRUB to choose distros. I added Slackware 12.0 (downloaded yesterday) with no Lilo but I did ask it to make a USB boot drive. The USB stick is blank so now I don't know what to add to my menu.lst to have Slackware as an option.

    I then decided to load Slackware on another system by itself, using Lilo, and figure out some settings to begin guessing with. It wouldn't load. I got a GRUB Loading Error 17 message.

    Does anyone have an idea what I can do to get access to my Slackware distro?



  2. #2
    SuperMod (Back again) devils casper's Avatar
    Join Date
    Jun 2006
    Chandigarh, India
    Mount Slackware partition in Mandriva and check the contents of /boot folder of Mandriva. Note down vmlinuz and intrid filenames. Add this in Mandriva's menu.lst file
    title Slackware
    root (hd0,x)
    kernel /<vmlinuz_filename> ro root=/dev/hda<partition>
    initrd  /<initrd_filename>
    Replace x with Slackware partition number - 1. Type correct vmlinuz and initrd filenames.
    Save file and reboot machine. Select Slackware in Menu.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Slackware didn't load an initrd... file. I have this README.initrd@ entry that blinks, but I can't find the way to open it. I need to find out what that's about. I think I read somewhere that if you use the huge-smp version you don't need the initrd file. I understand that the initrd file is meant to work at the beginning or during the boot process, which seems to indicate it is needed.

    # ls /slackware/boot
    config@                          diag1.img                                vmlinuz-huge-
    config-generic-          README.initrd@                   vmlinuz-huge-smp-
    Could Mandriva have done something to the MBR to preven both Slackware and Fedora from modifying it? I've since loaded Fedora somewhat successfully, loading really was a breeze - especially working with partitions, but the system booted up to the Mandriva grub screen. I expected to end up with a Fedora version of bootloader that I would again have to modify to include the other distros like I did Mandriva. Instead I modified Mandriva and am able to boot into Fedora.

    The bottom line is, I guess it can't hurt too much to try and figure out a way to boot Slackware. I read that there is a initrd utility on the CD/DVD to make this file but I couldn't find it. I did notice the fedora menu.lst file was quite different than the others:

    title Fedora (
            root (hd0,9)
            kernel /boot/vmlinuz- ro root=LABEL=/ rhgb quiet
            initrd /boot/initrd-

    Most notably was the entry after root= on the kernel line. I've got plenty to learn.

    Thanks for any input.


  4. $spacer_open
  5. #4
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    West Yorks
    An initial ramdisk image (initrd) is not strictly needed if everything you need to get the system going is compiled into the kernel. I never used to created initrd images when I compiled my own kernels for Slackware and Gentoo. You can use the mkinitrd command to create your own initrd image. I guess this is the tool thats supposed to be on the Slackware disk.

  6. #5

    slack in grub

    Hi there,

    Struggled with my installation of Slackware 12.2 yesterday, and stumbled across this posting.

    I to tried to make an USB bootstick, but that failed on my again and again. The setup states the USB stick will be wiped out, so I thought it would eat my windows formatted (probably FAT16) usb stick. Didn't. Used my Ubuntu installation to get the stick empty and ext3 formatted: slackware setup still didn't eat the stick. oh yes, it does detect and 'mount', but in the end, it won't boot from it ( checking: the're nothing on the stick either ).

    So no boot-usb stick, no initrd like vuserv and no working slackware.

    I thought, no initrd -> thus installation failed somewhere.

    Option via LILO on a boot floppy maybe?
    I tried to skip the LILO installation cause I've got Grub already, did notice a floppy option ones, but with a restart of the setup, I couldn't find the boot-lilo-floppy option anymore..

    That didn't help me either.

    The 'blinking' README.initrd@ which vuserv mentioned got me thinking I ****ed up likewise. This wasn't the case: README.initrd@ is just a link to file somewhere on the filesystem of the installed slackware.
    When you mount the slackware 'disk' from another running linux ( in my case from ubuntu ) by
    sudo mkdir /media/slackware
    sudo mount /dev/sda6 /media/slackware
    ls /media/slackware/boot
    the 'link' in /media/slackware/boot/README.initrd@ is directed to /usr/doc/mkinitrd-1.3.2/README.initrd
    There's nothing there in the ubuntu system. You should look for this file in /media/slackware/usr/doc/mkinitrd-1.3.2/README.initrd


    Just adding that finally I did manage to get it working with following lines in the menu.lst of grub:

    title           Slackware linux 12.2
    root            (hd0,5)
    kernel          /boot/vmlinuz-huge-smp- root=/dev/sda6 ro

    In the help that was given above, the /boot just wasn't there. That's why my Grub stopped with a error 15 ( file not found )...
    First I thought the missing initrd img was what caused the grub failure.

    It took me quite some time to figure out that slackware can be started without specifing the initrd ( see above)

    My ubuntu's are listed like this:
    title		Ubuntu 8.10, bla bla
    uuid		486096abla bla bla 
    kernel		/boot/vmlinuz-2.6.27-7-genebla bla
    initrd		/boot/initrd.img-2.6.27-7-generic
    And then it hit me: /boot was missing! and the initrd isn't mandatory to get my slackware running!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts