Find the answer to your Linux question:
Results 1 to 6 of 6
Hi all, i'm a newbie to linux. I'm using a slackware 12.0 dvd on a Acer 4520 laptop(Amd 64 Turion X-2 2.0 ghz, nVidia Heforce 7000m, hitachi 120gb hd) During ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2008
    Posts
    18

    Partition not detected


    Hi all, i'm a newbie to linux. I'm using a slackware 12.0 dvd on a Acer 4520 laptop(Amd 64 Turion X-2 2.0 ghz, nVidia Heforce 7000m, hitachi 120gb hd)

    During the cfdisk partition, it only shows the free disk space of 4.6gb. Although i have windows XP installed in a different partition and another total unpartitioned space of 15gb.

    And when i run lspci with a different livecd, most of the components are labeled as nVidia Corporation: Unknown Device

    Any idea bout it?
    Thx

  2. #2
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    Welcome to the forums!

    The Slackware DVD gives you the chance of running commands from the command line before the installation begins.
    Can you post the output of this command?
    Code:
    fdisk -l
    EDIT:
    Only after pressing 'submit' it occurred to me that this may happen sometimes when people run cfdisk on a system where the setup of mass storage devices isn't what the default values of cfdisk expects. I have a distinct feeling that your system is like that.
    As cfdisk can handle only one disk at a time it defaults to /dev/hda is no argument is given. It finds a space of 4,6GB you say?? Coincidence? I think you're unknowingly are attempting to partition the install DVD
    You might want to try
    Code:
    cfdisk /dev/sda
    As a quick attempt to fixing this. Please post back your results.
    Can't tell an OS by it's GUI

  3. #3
    Just Joined!
    Join Date
    Feb 2008
    Posts
    18
    fdisk -1 returned as invalid command. It needed an additional command after the -1.

    Anyway, cfdisk /dev/sda worked. Thanks
    But half of my hardwares still remained as unknown device. What shud i do bout it?

  4. $spacer_open
    $spacer_close
  5. #4
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Quote Originally Posted by miux View Post
    fdisk -1 returned as invalid command. It needed an additional command after the -1.
    Just so you'll know for the next time, it's a lowercase letter "l", and not a numeral 1. Don't worry though, because it's a very common error.

    Tell us more about your unknown hardware.
    oz

  6. #5
    Just Joined!
    Join Date
    Feb 2008
    Posts
    18


    Thats from the nimblex livecd. Its bout the same result with the slackware 12.0 now. But the audio and ethernet controller are detected in the slackware. The rest still remain unknown

  7. #6
    Linux Newbie stinkoman's Avatar
    Join Date
    Jan 2008
    Location
    New Jersey
    Posts
    175
    try cfdisk /dev/hdb or cfdisk /dev/sda or cfdisk /dev/sdb
    (i think it assumes hda when just cfdisk is used)
    please click my minicity!
    or its industry more or even its roads
    Everyone is immortal until the day they die.
    Registered Linux user #462038

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •