Find the answer to your Linux question:
Results 1 to 2 of 2
I just installed slackware 12 today and i'm having some trouble getting my realtek ac'97 sound card to work. first i tried installing the realtek-linux-audiopack-5.01 driver from the realtek site ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2007
    Posts
    8

    ac97 audio trouble


    I just installed slackware 12 today and i'm having some trouble getting my realtek ac'97 sound card to work. first i tried installing the realtek-linux-audiopack-5.01 driver from the realtek site using the automated install process but when the installer tries to detect a card or onboard chip, it comes up with nothing. I'm 100% sure it's an on-board realtek chipset 'cause that's what was installed on XP before i got rid of it :P I did kill ALSA related processes before installing btw so that's not causing a problem. Keep in mind i'm really new to linux so try and keep things simple for this noob :)

    Here's lsmod:
    Module Size Used by
    ipv6 254496 16
    pcmcia 34988 0
    pcmcia_core 36500 1 pcmcia
    capability 7304 0
    commoncap 9344 1 capability
    lp 13736 0
    parport_pc 27812 1
    parport 34760 2 lp,parport_pc
    pcspkr 6528 0
    psmouse 39048 0
    fglrx 1469132 22
    amd64_agp 13572 1
    agpgart 31432 2 fglrx,amd64_agp
    serio_raw 9220 0
    pata_amd 13964 0
    k8temp 8320 0
    hwmon 6404 1 k8temp
    i2c_nforce2 8704 0
    sg 30364 0
    ata_generic 9220 0
    evdev 11904 1
    shpchp 33172 0
    forcedeth 46728 0

    lspci (JUST THE PART LISTING THE AUDIO CONTROLLER):
    00:06.0 Multimedia audio controller: nVidia Corporation nForce3 250Gb AC'97 Audio Controller (rev a1)
    Subsystem: Micro-Star International Co., Ltd. Unknown device 7585
    Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 11
    I/O ports at ec00 [size=256]
    I/O ports at e800 [size=128]
    Memory at fe02b000 (32-bit, non-prefetchable) [size=4K]
    Capabilities: [44] Power Management version 2

    I have sound set to ALSA in KDE ControlCenter/Sound System and any time i try to restart the sound server, i get the message; device: default can't be opened for playback (no such device). Please help a noob out!

  2. #2
    Just Joined!
    Join Date
    Dec 2007
    Posts
    8
    ok i got it working! sorry about the wasted post. looks like the driver came preinstalled in slack after all but it just wasn't configured. when i tried to installed the drivers from realtek, it must have broken something and prevented alsaconf from finding any audio hardware. after reinstalling slackware and then running alsaconf, the soundcard was detected, and now i'm set

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •