Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 28
I just went through the very process I gave to you and don't receive that error. Hmmm. Let's see if it's where it's supposed to be. Do as su: Code: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630

    I just went through the very process I gave to you and don't receive that error. Hmmm. Let's see if it's where it's supposed to be. Do as su:
    Code:
    updatedb
    When it finishes...
    Code:
    locate ath_pci
    ...and post the output here please.

    EDIT: When you did "make" did you get something that looked like this?
    Code:
    /bin/sh: line 0: cd: /lib/modules/2.6.24.1/build: No such file or directory
    Makefile.inc:66: *** /lib/modules/2.6.24.1/build is missing, please set KERNELPATH.  Stop.
    ?
    Linux Mint + IceWM Registered: #371367 New Members: click here

  2. #12
    Just Joined!
    Join Date
    Feb 2008
    Posts
    18
    Code:
    root@localdomain:~# locate ath_pci
    /lib/modules/2.6.21.5-smp/net/ath_pci.ko
    /home/miux/Desktop/downloads/updates/madwifi-0.9.4/ath/if_ath_pci.c
    /home/miux/Desktop/downloads/updates/madwifi-0.9.4/ath/if_ath_pci.h
    /home/miux/Desktop/downloads/updates/madwifi-0.9.4/ath/if_ath_pci.o
    /home/miux/Desktop/downloads/updates/madwifi-0.9.4/ath/ath_pci.o
    /home/miux/Desktop/downloads/updates/madwifi-0.9.4/ath/.ath_pci.o.cmd
    /home/miux/Desktop/downloads/updates/madwifi-0.9.4/ath/.if_ath_pci.o.cmd
    /home/miux/Desktop/downloads/updates/madwifi-0.9.4/ath/ath_pci.mod.c
    /home/miux/Desktop/downloads/updates/madwifi-0.9.4/ath/ath_pci.mod.o
    /home/miux/Desktop/downloads/updates/madwifi-0.9.4/ath/ath_pci.ko
    /home/miux/Desktop/downloads/updates/madwifi-0.9.4/ath/.ath_pci.ko.cmd
    /home/miux/Desktop/downloads/updates/madwifi-0.9.4/ath/.ath_pci.mod.o.cmd
    /home/miux/Desktop/downloads/updates/madwifi-0.9.4/.tmp_versions/ath_pci.mod
    /root/Desktop/download/madwifi-0.9.4/ath/if_ath_pci.c
    /root/Desktop/download/madwifi-0.9.4/ath/if_ath_pci.h
    /root/Desktop/download/madwifi-0.9.4/ath/if_ath_pci.o
    /root/Desktop/download/madwifi-0.9.4/ath/ath_pci.o
    /root/Desktop/download/madwifi-0.9.4/ath/.ath_pci.o.cmd
    /root/Desktop/download/madwifi-0.9.4/ath/.if_ath_pci.o.cmd
    /root/Desktop/download/madwifi-0.9.4/ath/ath_pci.mod.c
    /root/Desktop/download/madwifi-0.9.4/ath/ath_pci.mod.o
    /root/Desktop/download/madwifi-0.9.4/ath/ath_pci.ko
    /root/Desktop/download/madwifi-0.9.4/ath/.ath_pci.ko.cmd
    /root/Desktop/download/madwifi-0.9.4/ath/.ath_pci.mod.o.cmd
    /root/Desktop/download/madwifi-0.9.4/.tmp_versions/ath_pci.mod
    No, i didnt get that output from 'make'

  3. #13
    Just Joined!
    Join Date
    Mar 2008
    Location
    Canada
    Posts
    42
    My guess right now would be that you've got multiple kernels installed and you're not running the one that the ath_pci.ko module was installed for. Can you post the result of running uname -r at the prompt?

  4. $spacer_open
    $spacer_close
  5. #14
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    That's my thinking as well John A. miux, can we also see the results of:
    Code:
    ls /lib/modules
    Code:
    ls /usr/src
    Code:
    ls /boot
    Linux Mint + IceWM Registered: #371367 New Members: click here

  6. #15
    Just Joined!
    Join Date
    Feb 2008
    Posts
    18
    uname -r
    Code:
    2.6.21.5
    ls /lib/modules
    Code:
    2.6.21.5/  2.6.21.5-smp/
    ls /usr/src
    Code:
    linux@  linux-2.6.21.5/  rpm/
    ls /boot
    Code:
    README.initrd@                       config-generic-smp-2.6.21.5-smp
    System.map@                          config-huge-2.6.21.5
    System.map-generic-2.6.21.5          config-huge-smp-2.6.21.5-smp
    System.map-generic-smp-2.6.21.5-smp  diag1.img
    System.map-huge-2.6.21.5             map
    System.map-huge-smp-2.6.21.5-smp     vmlinuz@
    boot.0800                            vmlinuz-generic-2.6.21.5
    boot_message.txt                     vmlinuz-generic-smp-2.6.21.5-smp
    config@                              vmlinuz-huge-2.6.21.5
    config-generic-2.6.21.5              vmlinuz-huge-smp-2.6.21.5-smp

  7. #16
    Just Joined!
    Join Date
    Mar 2008
    Location
    Canada
    Posts
    42
    Yep, it's as I suspected... you're running 2.6.21.5, but the modules were installed for 2.6.21.5-smp. From what I can tell, the linux-2.6.21.5 directory in /usr/src is actually the source for 2.6.21.5-smp, which would make sense (madwifi installed under the only kernel headers it could find). Since you don't have the kernel source for plain-old 2.6.21.5, your easiest solution would probably be to use the 2.6.21.5-smp kernel.

    Back up your old vmlinuz sym-link:
    Code:
    su
    [enter password]
    cd /boot
    mv vmlinuz vmlinuz.old
    Now create a new sym-link to the 2.6.21.5-smp kernel:
    Code:
    ln -s vmlinuz-generic-smp-2.6.21.5-smp vmlinuz
    If you're using GRUB as your bootloader, just reboot. If you're using lilo, run the following to update the MBR:
    Code:
    lilo
    Everything should boot fine, and then try modprobe'ing again.

  8. #17
    Just Joined!
    Join Date
    Feb 2008
    Posts
    18
    Lol, bad news

    Now my boot got stucked at
    Code:
    ACPI: Using IOAPIC for interrupt routing during boot
    The boot only resumes when i hit the power button once. Then it came down to this
    Code:
     Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,3)

  9. #18
    Just Joined!
    Join Date
    Mar 2008
    Location
    Canada
    Posts
    42
    Heh, sorry about that... that kernel is probably missing a few drivers. Perhaps the best thing to focus on right now is restoring your old kernel. My bad, I should have told you to create another entry in /etc/lilo.conf for vmlinuz.old... but anyway.

    Boot from your Slackware install disk, and then at the prompt, mount your root partition with something like:
    Code:
    mkdir /mnt/slackware
    mount /dev/hda3 /mnt/slackware
    Replacing 'hda3' with your hard disk device. If you've got any extra important partitions on your disk, mount them too:
    Code:
    mount /dev/hda4 /mnt/slackware/boot
    Now mount your proc filesystem:
    Code:
    mount -t proc none /mnt/slackware/proc
    and your devices filesystem:
    Code:
    mount -o bind /dev /mnt/slackware/dev
    You should now be able to chroot into your Slackware environment:
    Code:
    chroot /mnt/slackware /bin/bash
    Now just 'mv' your vmlinuz.old to vmlinuz again, and then run lilo to update your boot sector.

  10. #19
    Just Joined!
    Join Date
    Feb 2008
    Posts
    18
    When i command
    Code:
    mount -o bind /dev /mnt/slackware/dev
    It returned
    Code:
    mount: wrong fs type, bad option, bad superblock on /dev, missing codepage or other error. In some cases useful info is found in syslog - try dmesg | tail or so

  11. #20
    Just Joined!
    Join Date
    Mar 2008
    Location
    Canada
    Posts
    42
    Gah... I forgot that the Slackware install disk isn't setup for binding /dev filesystems.

    I'm not sure if simply changing the symbolic link will work, as I can't remember if lilo internally traverses symbolic links or not... in any case, it's worth a shot:
    Code:
    cd /mnt/slackware/boot
    mv vmlinuz vmlinuz.old2
    mv vmlinuz.old vmlinuz
    Try rebooting, and see if that makes a difference.

    My apologies for screwing up your system.

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •