Find the answer to your Linux question:
Page 3 of 3 FirstFirst 1 2 3
Results 21 to 28 of 28
Erm, there's no such directory under /mnt Its alrite I'm grateful that u guys are helping me out with it....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Just Joined!
    Join Date
    Feb 2008
    Posts
    18

    Erm, there's no such directory under /mnt

    Its alrite I'm grateful that u guys are helping me out with it.

  2. #22
    Just Joined!
    Join Date
    Mar 2008
    Location
    Canada
    Posts
    42
    Sorry, I meant after you mount your partitions under the install disk, so something like this after you've booted from the CD:
    Code:
    mkdir /mnt/slackware
    mount /dev/hda3 /mnt/slackware
    Replace '/dev/hda3' with whatever your hard drive partition is. Then do:
    Code:
    cd /mnt/slackware/boot
    mv vmlinuz vmlinuz.old2
    mv vmlinuz.old vmlinuz

  3. #23
    Just Joined!
    Join Date
    Feb 2008
    Posts
    18
    Phew, finally all back to the usual. lol

    So where are we now? Got sidetracked till i almost forgot whats the main problem :P

  4. #24
    Just Joined!
    Join Date
    Mar 2008
    Location
    Canada
    Posts
    42
    Sorry about the delay. Download the following package:
    http://www.kernel.org/pub/linux/kern...6.21.5.tar.bz2

    Then go to the command prompt, 'cd' to the directory that you downloaded it into, and then run the following:
    Code:
    su
    <enter password>
    tar xjf linux-2.6.21.5.tar.bz2 -C /usr/src
    Now 'cd' back to where ever your madwifi source is, and type the following:
    Code:
    export KERNELPATH=/usr/src/linux-2.6.21.5
    make
    make install
    You should now be able to 'modprobe ath_pci'.

  5. #25
    Just Joined!
    Join Date
    Feb 2008
    Posts
    18
    still the same results. module ath_pci not found

  6. #26
    Just Joined!
    Join Date
    Mar 2008
    Location
    Canada
    Posts
    42
    Perhaps installing a new kernel would be the best option, then. 'cd' back to where you downloaded linux-2.6.21.5.tar.bz2, then gain root access (su).

    1. Extract the Linux tarball into your current directory:
    Code:
    tar xjf linux-2.6.21.5.tar.bz2
    2. move/rename it so there won't be any confusion:
    Code:
    mv linux-2.6.21.5 /usr/src/linux-custom-2.6.21.5
    3. copy the old kernel configuration over:
    Code:
    cp /boot/config-generic-2.6.21.5 /usr/src/linux-custom-2.6.21.5/.config
    4. Now make sure there aren't any missing configuration options:
    Code:
    cd /usr/src/linux-custom-2.6.21.5
    make oldconfig
    If it asks you any questions, just respond with the default answer (hit 'enter'), you probably won't mess it up. :P

    5. Now build the kernel and install its modules:
    Code:
    make && make modules_install
    6. Once that's done, install the new kernel:
    Code:
    cp arch/i386/boot/bzImage /boot/bzImage-2.6.21.5
    7. Edit your /etc/lilo.conf file. Find your 'image=' entry, then copy it. It should look something like this:
    Code:
    image=/boot/vmlinuz
       label=Linux
       root=/dev/hda1
    It might look a little bit different. Anyhow, copy this block down right below itself. In the copy that you just made of the image block, change vmlinuz to bzImage-2.6.21.5, and Linux to Linux-new. This will create a new entry in your Lilo bootloader that will allow you to use the new kernel (but this time you can still revert back to the old kernel if the new one doesn't work for some reason ).

    8. Now update 'lilo':
    Code:
    /sbin/lilo
    It should print out any errors if there is a problem with your configuration file. Reboot, and try out the new kernel (Linux-new).

    Once you've verified that the new kernel is working, proceed on with the madwifi installation:

    1. 'cd' to where your madwifi source directory is.
    2. Now run this:
    Code:
    export KERNELPATH=/usr/src/linux-custom-2.6.21.5
    make
    make install
    That *should* work.

  7. #27
    Just Joined!
    Join Date
    Feb 2008
    Posts
    18
    Lol, sorry...but i'm a little lost in step 7. Bout finding,copying and changing it.
    The rest went well,from 1 to 6

  8. #28
    Just Joined!
    Join Date
    Feb 2008
    Posts
    18
    Code:
     Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,3)

    So how do i revert it back?
    i've done all the steps u suggested precisely, modprobe ath_pci didnt return any errors, but this happened when i reboot

Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •