Find the answer to your Linux question:
Results 1 to 2 of 2
I am trying to install Kismet log viewer on slackware 10. I think this is the only program that will allow me to view the kismet.dump and kismet.xml files. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    17

    Question on installing Log Viewer for Kismet


    I am trying to install Kismet log viewer on slackware 10. I think this is the only program that will allow me to view the kismet.dump and kismet.xml files.
    I already have perl-5.8.4-i486-3 installed and I downloaded XML-LibXML-1.58_1 from http://search.cpan.org/~phish/XML-LibXML-1.53/
    When trying to install XML-LibXML I get this error message:

    08:21:34 X01A4:/opt/kismet-log-viewer-0.9.7$./klv.pl New-Kismet-Comb-Log2.xml
    Can't locate XML/LibXML/Common.pm in @INC (@INC contains: /usr/lib/perl5/5.8.4/i486-linux /usr/lib/perl5/5.8.4 /usr/lib/perl5/site_perl/5.8.4/i486-linux /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl .) at /usr/lib/perl5/site_perl/5.8.4/i486-linux/XML/LibXML.pm line 11.
    BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.4/i486-linux/XML/LibXML.pm line 11.
    Compilation failed in require at ./klv.pl line 77.
    BEGIN failed--compilation aborted at ./klv.pl line 77.
    08:21:56 X01A4:/opt/kismet-log-viewer-0.9.7$


    Im a bit confused what I need to do to install this.

    All I want to do is view my files I get from Kismet. Any help with this would be GGGreat!!!

    Thanks

  2. #2
    Just Joined!
    Join Date
    Jul 2004
    Posts
    17
    okay i fixed this.
    What I ended up having to do was download all the other programs that needed to go along with this.
    The programs I downloaded were:
    - libxml2-2.6.8
    - XML-LibXML-Common-0.13
    - XML-NamespaceSupport-1.08
    - XML-SAX-0.12
    - XML-LibXML-1.58

    After installing those I still got an error at the end of the "make install" command. It said it could not find a file #/usr/lib/perl5/site_perl/5.8.4/XML/SAX/ParserDetails.ini

    But when I went to that location it did have the ParserDetails.ini file already there. So I just ran the "#make install" again and for some reason it worked fine. Now everything seems to be working good

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •