Find the answer to your Linux question:
Results 1 to 7 of 7
Hi there, Heres my scenario, ive downloaded the slackware iso(everything) and burnt as an image on a DVD with my DVD-ROM thats connected to my logic board via EIDE(ata-6). My ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2008
    Posts
    6

    Thumbs up Setup not detecting EIDE DVD-ROM


    Hi there,

    Heres my scenario, ive downloaded the slackware iso(everything) and burnt as an image on a DVD with my DVD-ROM thats connected to my logic board via EIDE(ata-6).

    My hardware:

    Asus P5K SE Motherboard
    Marvell 88SE6111 IDE Controller
    1 x SATA-2 HD
    1 x EIDE(DVD-ROM device connected)

    Ive successfully booted the image, and loaded the kernel(hugesmp.s)

    Partitioned the space on my (only) Hard drive being a SATA-2 connection

    Ive entered the setup interface, and got as far as selecting the source media

    However slack cannot detect my DVD-ROM with the image(which i assume contains the source media)

    I've read elsewhere that the Marvell IDE controller is problematic, so i passed this option to the kernel when i boot = "hugesmp.s all-ide-generic"
    But that does not help either.

    so im stuck at this point, any advice much appreciated

  2. #2
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    Well, that's odd.

    I take it when you partitioned your HD, you issued
    Code:
    cfdisk /dev/sda
    What does "fdisk -l" say?? (-l is small L)
    And "mount"? (without options, just to see which devices are mounted)

    Did you try to select the DVD-ROM manually? The installer gives that option.

    ---

    It could be, but I'm by no means certain, that the naming scheme confuses the installer. I know that when you have a SATA HD and an IDE CDROM that this confuses the default assumptions of cfdisk. You'll need to specify manually then (hence my question about it above).
    Maybe the DVD-ROM is called something exotic like /dev/hdg1 that the installer can't pick it up?? Try to find out using 'mount' or 'fdisk -l' and see if you can reach it manually through the installer.


    Quote Originally Posted by KiwiJoker
    I've read elsewhere that the Marvell IDE controller is problematic, so i passed this option to the kernel when i boot = "hugesmp.s all-ide-generic"
    That is good reasoning. Trying kernel boot parameters is a good plan B. But let's first rule out that it's not something simpler.
    Can't tell an OS by it's GUI

  3. #3
    Just Joined!
    Join Date
    Apr 2008
    Posts
    6
    Hi there,

    Actually i had my partitions layed out before i booted from the slack image,

    when I run fdisk -l

    i get:

    /dev/sda1 = (windows)
    /dev/sda4 = (linux primary)
    /dev/sda5 = (linux extended)
    /dev/sda6 = (linux swap)

    /dev/sdb1 = (flash drive)

    But ive found a work around for now, i just extracted the needed dir for the setup process from the slack iso, and placed in a partition before i actually booted with slack, then directed the setup to find the source media on the HD partition, which worked fine

    However, I still havent resolved this DVD issue, the device is just not being picked up

  4. #4
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    You fixed that quite nice
    You're no stranger to *nix then??


    Just out of curiosity

    What does this say?
    Code:
    file /dev/dvd
    Can't tell an OS by it's GUI

  5. #5
    Just Joined!
    Join Date
    Apr 2008
    Posts
    6
    Kiwi@darkstar:~$ file /dev/dvd
    /dev/dvd: cannot open `/dev/dvd' (No such file or directory)
    Kiwi@darkstar:~$

  6. #6
    Just Joined!
    Join Date
    Apr 2008
    Posts
    6
    Well i upgraded my kernel to the current 2.6.24.4-smp kernel release, and now my DVD-ROM writer/burner is working well, =)

    dmesg | grep CD :

    scsi 6:0:0:0: CD-ROM ASUS DRW-1814BL 1.13 PQ: 0 ANSI: 5
    Uniform CD-ROM driver Revision: 3.20
    sr 6:0:0:0: Attached scsi CD-ROM sr0

  7. #7
    Just Joined!
    Join Date
    Sep 2008
    Location
    Quetta
    Posts
    1

    Help needed

    Quote Originally Posted by KiwiJoker View Post
    Hi there,

    Actually i had my partitions layed out before i booted from the slack image,

    when I run fdisk -l

    i get:

    /dev/sda1 = (windows)
    /dev/sda4 = (linux primary)
    /dev/sda5 = (linux extended)
    /dev/sda6 = (linux swap)

    /dev/sdb1 = (flash drive)

    But ive found a work around for now, i just extracted the needed dir for the setup process from the slack iso, and placed in a partition before i actually booted with slack, then directed the setup to find the source media on the HD partition, which worked fine

    However, I still havent resolved this DVD issue, the device is just not being picked up
    Hi
    I am facing the exact problem. I am installing RHEL 3.....and I have SATA HD and IDE DVD-ROM.........
    the solution that u have given, can u plz explain it further as to which dir did u extract from the iso and placed it in ur HDD........
    thnx....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •