Find the answer to your Linux question:
Page 1 of 6 1 2 3 4 5 ... LastLast
Results 1 to 10 of 55
Hello all. I have Slackware 12.0 installed and I'm trying to transfer data on my USB stick from PC to Linux. Whenever I access the folder containing the USB stick, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2008
    Location
    Ontario
    Posts
    76

    Question How to disable USB security?


    Hello all. I have Slackware 12.0 installed and I'm trying to transfer data on my USB stick from PC to Linux. Whenever I access the folder containing the USB stick, I get a dialog box that says I don't have permission to receive this "message". I am logged in as root, so what the...

    Peter

  2. #2
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    Sometimes not even root has enough permissions. But not in simple tasks like file transfer between media.

    Can you post the output of these commands (issued when you receive said message)

    Code:
    mount
    Checks whether the device is mounted

    Code:
    lsusb
    Checks whether the device is recognized

    And, a couple of seconds after you plug in the device:
    Code:
    dmesg | tail
    To see the kernel response.

    It could be, but I'm not sure, that the device was not properly unmounted. That sometimes causes problems.
    Can't tell an OS by it's GUI

  3. #3
    Just Joined!
    Join Date
    Apr 2008
    Location
    Ontario
    Posts
    76

    Exclamation Output from test

    Hi. Here is the output. I apologize in advance for any typos.
    # mount
    /dev/sda1 on /type ext3 (rw)
    proc on /proc type proc (rw)
    sysfs on /sys type sysfs (rw)
    usbfs on /proc/bus/usb type usbfs (rw)

    #lsusb
    Bus 3 Device1:ID XXXX:XXXX
    Bus 3 Device2:ID XXXX:XXXX Alcor Micro Corp
    Bus 1 Device6:ID XXXX:XXXX Feiya Technology Memory Bar
    Bus 1 Device1
    Bus 2 Device2

    #dmesg | tail
    sdf: Mode Sense 43 00 00 00
    sdf: assuming drive cache: write through
    SCSI device sdf 7929856 512-byte hdwr sectors (4060MB)
    sdf:Write protect is off
    sdf: Mode Sense 43 00 00 00
    sdf: assuming drive cache: write through
    sdf:sdf1
    sd 8:0:0:0 Attached scsi removable disk sdf
    sd 8:0:0:0 Attached scsi generic sg5 type 0
    usb-storage device scan complete

    Whew!

    Peter

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Post the output of fdisk -l command here. Its small L in fdisk -l.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined!
    Join Date
    Apr 2008
    Location
    Ontario
    Posts
    76

    Angry More diagnostics

    I'm sorry but I'm just not in the mood to write all that down. But I can tell you that from what I see is that the machine definitely sees a 4GB stick on /dev/sdf1. Interestingly, when I umounted that drive, it said it was not mounted.

    Peter

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Have you tried to mount /dev/sdaf1 using mount command? What error message does it throw?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    Quote Originally Posted by pfeigl
    I'm sorry but I'm just not in the mood to write all that down. But I can tell you that from what I see is that the machine definitely sees a 4GB stick on /dev/sdf1. Interestingly, when I umounted that drive, it said it was not mounted.
    Ehm... you are the one requesting help. These diagnosis are part of helping you. That's the Bad News. The Good News is that you can just copy&paste from the terminal to the browser while posting. I sure wouldn't have felt like retyping all that either. I let my computer do that

    Quote Originally Posted by devils casper
    Have you tried to mount /dev/sdaf1 using mount command? What error message does it throw?
    Probably (as root) mount: can't find /dev/sdf1 in /etc/fstab or /etc/mtab
    And as user: mount: can't find /dev/sdf1 in /etc/fstab or /etc/mtab
    Don't you think


    I'm thinking there just needs to be an entry in fstab. But before that try this command: (as root)
    Code:
    mkdir /mnt/usb ; mount /dev/sdf1 /mnt/usb ; ls /mnt/usb
    ---

    Quote Originally Posted by pfeigl
    But I can tell you that from what I see is that the machine definitely sees a 4GB stick on /dev/sdf1. Interestingly, when I umounted that drive, it said it was not mounted.
    fdisk doesn't need the device to be mounted in order to see it. It sees unmounted devices as well. From your other post I can see that your USB stick wasn't mounted, but did indeed get recognized.
    I still can't explain the error message you received. But if the previous command worked, then that may not matter. You'll need to edit fstab so you can mount your usb as regular user.
    Can't tell an OS by it's GUI

  8. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Quote Originally Posted by Freston
    Probably (as root) mount: can't find /dev/sdf1 in /etc/fstab or /etc/mtab
    And as user: mount: can't find /dev/sdf1 in /etc/fstab or /etc/mtab
    Don't you think
    Thats why I suggested him to mount /dev/sdaf1 using mount command. It doesn't mean TS has to execute mount command only. He/she has to specify device name along with other options, like the way you suggested.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #9
    Just Joined!
    Join Date
    Apr 2008
    Location
    Ontario
    Posts
    76

    USB Troubles

    Hello. I was writing it down because I wasn't using that machine to post. Doh! I will try what you said but when I put the stick in a dialog pops up right away asking if I want to open it or do nothing. Of course if I choose the former I get the security message.

    Peter

    P.S. No, there are no security "features" on the stick.

  10. #10
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Execute this :
    Code:
    mkdir usb
    mount -t vfat /dev/sdf1 usb -o defaults,umask=0
    ls usb
    Post exact error message here, if any.
    I assumed that USB stick is formatted in FAT32 filesystem.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Page 1 of 6 1 2 3 4 5 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •