Find the answer to your Linux question:
Results 1 to 5 of 5
Here is my fstab: /dev/sda1 / ext3 noauto, user 0 0 /dev/cdrom /mnt/cdrom auto noauto,user ro 0 0 /dev/fd0 /mnt/floppy auto noauto,owner 0 0 devpts /dev/pts devpts gid=5,mode=620 0 0 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2008
    Location
    Ontario
    Posts
    76

    Exclamation How do I edit fstab so I can access my HDD?


    Here is my fstab:

    /dev/sda1 / ext3 noauto, user 0 0
    /dev/cdrom /mnt/cdrom auto noauto,user ro 0 0
    /dev/fd0 /mnt/floppy auto noauto,owner 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    proc /proc proc defaults 0 0
    ~

    I edited it to look like the CDROM entry and the CDROM works. The HDD doesn't.

  2. #2
    Linux Newbie
    Join Date
    Jan 2008
    Location
    UK
    Posts
    211
    This should give some ideas: this is my fstab.......

    LABEL=/ / ext3 defaults 1 1
    tmpfs /dev/shm tmpfs defaults 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    sysfs /sys sysfs defaults 0 0
    proc /proc proc defaults 0 0
    /dev/sda2 swap swap defaults 0 0

  3. #3
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    On a Vector machine (uncustomized):


    cat /etc/fstab
    # /etc/fstab: static file system information.
    #
    # The following is an example. Please see fstab(5) for further details.
    # Please refer to mount(1) for a complete description of mount options.
    #
    # Format:
    # <file system> <mount point> <type> <options> <dump> <pass>
    #
    # dump(8) uses the <dump> field to determine which file systems need
    # to be dumped. fsck(8) uses the <pass> column to determine which file
    # systems need to be checked--the root file system should have a 1 in
    # this field, other file systems a 2, and any file systems that should
    # not be checked (such as MS-initrd/mnt or NFS file systems) a 0.

    # The Linux partitions
    /dev/sda1 / reiserfs noatime 0 1
    /dev/sda3 /home reiserfs noatime 0 2

    # Shared Windows/Linux partition
    #/dev/hda1 /mnt/dos msdos umask=0 0 0
    #/dev/hda1 /mnt/win vfat fmask=111,dmask=0,quiet,shortname=mixed,user 0 0
    #/dev/hda1 /mnt/win ntfs umask=0 0 0

    # Floppy disks
    # The 'noauto' option indicates that the file system should not be mounted
    # with 'mount -a' 'user' indicates that normal users are allowed to mount
    # the file system.
    #/dev/fd0 /mnt/floppy auto defaults,noauto,user 0 0
    #/dev/fd1 /mnt/floppy auto defaults,noauto,user 0 0

    # If you have a ls-120 floppy drive, it could be on /dev/hda b c d etc.
    #/dev/hdd /mnt/ls120 auto defaults,noauto,user 0 0

    # CDROM, CDWRITER, DVD
    /dev/cdrom /mnt/cdrom iso9660 defaults,noauto,ro,user 0 0
    #/dev/cdwriter /mnt/cdwriter iso9660 defaults,noauto,rw,user 0 0
    #/dev/dvd /mnt/dvd auto defaults,noauto,ro,user 0 0

    # NFS file systems:
    #linux01.gwdg.de:/suse/6.3/i386.de /mnt/nfs nfs defaults 0 0

    # proc file system:
    proc /proc proc defaults 0 0

    # Unix98 devpts filesystem:
    none /dev/pts devpts gid=5,mode=666 0 0

    # Shared memory filesystem:
    tmpfs /dev/shm tmpfs defaults 0 0

    # Basic USB filesystem
    sysfs /sys sysfs defaults 0 0
    usbfs /proc/bus/usb usbfs rw,devmode=0666 0 0

    # example of a VFAT USB pendrive
    #/dev/sda1 /mnt/pendrive vfat fmask=111,dmask=0,noauto,user,quiet,shortname=mixe d 0 0


    # Swap partitions
    # The 'sw' option means auto activating with 'swapon -a'.
    Can't tell an OS by it's GUI

  4. #4
    Just Joined!
    Join Date
    Apr 2008
    Location
    Ontario
    Posts
    76

    Lightbulb Hmmmm.

    I think the second line may be the problem. I'm also going to check fstab on my Debian box because it works. I can see the filesystem in the GUI.

    Peter

  5. #5
    Linux User
    Join Date
    Jan 2006
    Posts
    414
    try this:

    /dev/sda1 / ext3 defaults 1 1
    /dev/cdrom /mnt/cdrom auto noauto,user ro 0 0
    /dev/fd0 /mnt/floppy auto noauto,owner 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    proc /proc proc defaults 0 0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •