Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
I seem to be having trouble with serial ATA. Basically this is how my system is setup: Intel D865PERL mobo, P4 2.4GHz, 1GB Ram, on-board ICH5 integrated SATA controller, WD2000JD ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    17

    Slack 10 kernel 2.4.26 Intel ICH5 SATA


    I seem to be having trouble with serial ATA. Basically this is how my system is setup: Intel D865PERL mobo, P4 2.4GHz, 1GB Ram, on-board ICH5 integrated SATA controller, WD2000JD SATA HD. Like the subject says I'm using kernel 2.4.26 with Slackware 10. Yes, i know the distro contains kernel 2.6.7, but, I opted not to use it. I have Slack installed on a 20GB ATA-66 hard drive. All im trying to do is mount my WD drive in Slack so I can get to my Windoze XP files. When I boot into Slack with the SATA drive connected it just hangs. Stops at loading ide-drivers or something. I noticed during boot it shows the WD drive as "hdx" (not x but i dont remember right now, should say sdx right?). When I power down and disconnect the drive everything works fine but obviously I cant get to my files 'cause the drive is not connected. I have been reading that the 2.4.26 kernel does not support the ICH5 (obviously). Can someone guide me here? I also read that 2.4.27 does not support ICH5. Ahhhhhh.. im pulling my hair out. After I get this solved i will try to boot using the NT loader which seems pretty simple. bootsect.lnx ... thats about it. It would have really sucked if I tried to install on the WD to begin with but thats not what im trying to do so it doesnt really matter. Anyway if someone could point me in the right direction it would be appreciated.

  2. #2
    Just Joined!
    Join Date
    Aug 2004
    Posts
    17

    UPDATE

    Although there have not been any replies.. I did figure something out. In the BIOS if I go to my drive config and put everything in "Legacy Mode" I can successfully boot and access my SATA drive. Now.. This really sucks because if I want to go back into Windowze I will not have the through-put as I did in "Enhanced Mode." So, basically, I'm stuck. I need to know what kernel others have that works in the "Enhanced Mode." PLEASE! I'm very upset by this. Why does the kernel not have native SATA-150 support!?!

    Edit: I found that I have Slackware 10-RC1. No 2.6.7 kernel!

  3. #3
    Just Joined!
    Join Date
    Aug 2004
    Posts
    17

    (Another) Update !! Solved

    Well I got enough guts to go ahead and install kernel 2.6.7... Yup.. It recognizes my SATA dirve (although only ATA-133.. oh well) _AND_ I have the ability to boot into Slack using the NT loader. This is really working out great. I LOVE LINUX!!! Thanks to everyone for not replying (I mean it in a good way). I goes to show that if you dig deep enough you can get it done yourself. Oh.. did I say.. I LOVE LINUX.. yeah.. I already did.. It's worth it to say over and over again.!!

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Aug 2004
    Posts
    1
    nice post dude. I can't find from where I can enable my legacy in my bios.

  6. #5
    Just Joined!
    Join Date
    Aug 2004
    Posts
    17
    If you have the same motherboard that I do.. when you boot up enter the BIOS setup. Then go to Advanced >> Drive Configuration >> ATA/IDE Configuration. This is where you can change to "Legacy." Note that you can only enable SATA port 0/1 and ONE EIDE port. So if you're going to install from CD/DVD then make sure that you enable SATA ports 0 & 1 and whatever EIDE interface your CD/DVD drive is on. After all of this you need to know that you will have problems installing Slack on an SATA drive. You need a kernel that can use those ports. For some reason the 2.6.7 kernel is not pre-compiled on the Slackware 10 disc. Also the 2.6.7 kernel will recognize SATA drives as SCSI devices and the drive(s) will show up as "sdX" instead of "hdX" which can be a pain the ass when using LILO.

  7. #6
    Just Joined!
    Join Date
    Dec 2004
    Posts
    2
    Same Setup -- D865PERL -- SATA doesn't work.
    Going to try your resolution now.

  8. #7
    Just Joined!
    Join Date
    Dec 2004
    Posts
    2
    Your solution worked -- Thank you!

  9. #8
    Just Joined!
    Join Date
    Aug 2004
    Posts
    17

    Update

    As i mentioned before I installed Slackware onto a IDE drive. Bad news... that drive crashed on me. So instead of buying a whole new drive I said screw it. I backed up my data, formatted the WD SATA 200GB, partitioned for WinXP Slackware and FreeBSD. Before I get into my notes let me just say it runs rock solid.. no problems at all. Anyway, here are my notes/instructions:

    First, boot with the SATA drive in "Legacy" mode and the Slack boot/install CD inserted.

    Setup the partitions how you like them. I chose hda1 for XP as partition type 7 (NTFS), hda2 for Slackware 10 (type 82.. linux native), and hda3 for FreeBSD (type A5). Note I did not make any swap partitions.. I now have 2GB of DDR-400. Some might find that crazy, but, oh well.

    Then go ahead and install Slack. Reboot when it's done, of course. Compile a new kernel and do what you have to do to make it boot. NOTE: A new kernel means you have to RECOMPILE ALSA! I had to recompile ALSA for Kernel 2.4.28. Oh.. I should probably mention I not using 2.6.7 anymore.. heh. Reason is my video card.. Radeon with ATI's drivers require a 2.4 kernel.

    Reboot with SATA in "Enhanced" mode.

    Now the tricky part. Since I moved over to the SATA drive my root partition is now /dev/sda2. BEFORE you reboot into the new kernel make sure you edit /etc/fstab to reflect the new root. I also had another snag.. When I rebooted and the new kernel was starting it gave a panic.. "Unable to mount root device..." So I rebooted and at the LILO prompt I entered "linux-2.4.28 root=/dev/sda2" and well.. it worked! Pretty simple. Now make sure to update LILO!

    Ok, so Slack is installed and booting with SATA-150 (Actually 133) throughput.. man is that nice.

    Then I installed FreeBSD (5.2.1). No problem with SATA-150 at all.
    If you are going to install FreeBSD like in my setup here is another note.. DO NOT use the FreeBSD boot manager (boot0cfg, bteasy, ...) or install the MBR loader. Just choose NONE! You will be fine later. Another note: FreeBSD WILL mark it's partition with the boot flag.. meaning when you reboot you will get the FreeBSD boot menu. Read on...

    Now comes XP. With the previous mentioned problem I though I was screwed. Turns out Windows then marked it's partition with the boot flag. So Im ok. One thing I found out was you can manually mark whatever partition bootable. I used the cfdisk program to change that. As long as you dont modify the partitions but only change boot flags it works just fine. ... blah..blah XP is installed.

    Previously I had LILO on the super block of sda2. I booted into slack and edited /etc/lilo.conf and added XP Linux and FreeBSD. Then wrote it to the MBR. So now I can boot whatever I want. NOTE: If you write boot code to the MBR the partition marked bootable will NOT be booted. The BIOS looks for the MBR then the partition with the boot flag.

    Dont ask how I booted into slack after installing XP. Lets just say dd with NTLDR.

    I know this is sort of rough so please forgive me. If I said something out of order.. oops. Heh.. hope this helps someone.

  10. #9
    Just Joined!
    Join Date
    Dec 2004
    Location
    Tehran/Iran
    Posts
    5
    If you have slackeware 10 & a SATA hard disk,& your installer of slack doesn't detect your hard,Please enable Legacy in BIOS.Then you can see your hard disk in slack.

  11. #10
    Just Joined!
    Join Date
    Aug 2004
    Posts
    17

    .....

    Uhh.. thats exactly what I said to do.

    QUOTE: First, boot with the SATA drive in "Legacy" mode and the Slack boot/install CD inserted.

    "Legacy" will place the drive into ATA-100 mode NOT 150. Big performance difference. Which is why you need to compile a kernel with ICH5/6/-R SATA support and then place the drive back into "Enhcaned" mode after.

    Not sure if thats what you were getting at, but, like I said, I already mentioned it.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •