Find the answer to your Linux question:
Results 1 to 8 of 8
Hi All I have just returned to Slackware (12.1, was on 8.<something> when I last used it) and so far everything is working fine apart from a couple of very ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Aug 2004
    Location
    Malvern, UK
    Posts
    132

    Can't Drop to a Terminal with xfce!


    Hi All

    I have just returned to Slackware (12.1, was on 8.<something> when I last used it) and so far everything is working fine apart from a couple of very small niggles.

    Firstly I cannot drop to a terminal by using 'ctrl alt f2' etc. Nothing happens and I am left in xfce desktop.I have to actually logout of xfce to get the terminal back. When I don't have X running I can 'ctrl alt fn' through the terminals no problem. Restart X, and the problem comes back.

    Secondly when I first boot the Slack box I get framebuffer on the console with a nice res of 1024x768 and a friendly penguin to keep me company in the top left corner. This stays until I 'startx' and launch xfce. When I then log out of X the terminal seems to have dropped back to 800x600 and 'pingu' is missing.

    I am sure that these issue's can be easily resolved. I just don't know where to start looking. Can anyone point me in the right direction please.

    Cheers
    My Computer Once Beat Me at Chess, but it is No Match for Me at Kickboxing !

    Registered Linux User: #417183

  2. #2
    Linux User
    Join Date
    Mar 2008
    Posts
    287

    Can't Drop to a Terminal with xfce!

    Sounds like xorgconfig may have gotten some incorrect/spurious info.
    As a consequence of trying to ctrl/alt/+ and move between screen resolutions which I did with 10.2 (it is a long story), I now use a script to parse up the "Screen section" and after copying /etc/X11/xinit/... or /etc/xfce/xdg/xfce4/xinitrc to .xinitrc to allow selecting different window managers and permit myself to use different color depths and different resolutions.
    If you bootup to 1024x768 you would be in a window manager. If you then 'startx' (I think??) you are confusing the windows manager. Backing out may just be adding to its confusion.
    If you post your Screens section it may provide enlightenment.
    Do you intend to use TV on PC? or a webcam?

  3. #3
    Linux Newbie
    Join Date
    Aug 2004
    Location
    Malvern, UK
    Posts
    132
    Thanks for the reply Clickit:

    Here is my 'screen' section:

    Code:
    Section "Screen"
    
    #   DefaultDepth 16
    #   DefaultDepth 24
    #   DefaultDepth 32
    
        Identifier     "Screen 1"
        Device         "VESA Framebuffer"
        Monitor        "My Monitor"
        DefaultDepth    24
        SubSection     "Display"
            Depth       8
            Modes      "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection     "Display"
            Depth       16
            Modes      "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection     "Display"
            Depth       24
            Modes      "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection     "Display"
            Depth       32
            Modes      "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
    EndSection
    I started this as a fresh install of 12.1. Before launching 'X' at all I installed 'NVIDIA' drivers and then used 'nvidia-xconfig' to outline configure 'xorg.conf' before launching 'XFCE' via the 'startx' command.

    The display was then acceptable but a little fuzzy so I made a few changes to the screen section (adding 1280x1024 to depths 16, 24 and 32). That sharpened the display greatly and all things 'gui' appear to work very well, apart from the issue's outlined above.

    Interestingly, if I uncomment any of the default depth entries the display gets very fuzzy again.

    I have not poked about in 'X' configuration very much in the past so am a bit unsure where to look next. It provides a good opportunity to learn a bit more about the subject though

    Thanks for your help so far.

    Bubo
    My Computer Once Beat Me at Chess, but it is No Match for Me at Kickboxing !

    Registered Linux User: #417183

  4. #4
    Linux User
    Join Date
    Jan 2006
    Posts
    414
    I had the same problem with Ctrl+Alt+F* not working while X is running in Gentoo a little while ago; the problem was this line in my xorg.conf:
    Code:
    Option         "XkbVariant" "nodeadkeys"
    After commenting that out it all worked fine.

  5. #5
    Linux Newbie
    Join Date
    Aug 2004
    Location
    Malvern, UK
    Posts
    132
    Thanks for the suggestion. Just checked that line and it is already commented out.

    Back to the drawing board

    Bubo
    My Computer Once Beat Me at Chess, but it is No Match for Me at Kickboxing !

    Registered Linux User: #417183

  6. #6
    Linux User
    Join Date
    Mar 2008
    Posts
    287

    Can't Drop to a Terminal with xfce!

    Let me respond to your 1st 2 paragraphs.
    1) When I installed mine I used xorgconfig because I had googled about and found others having probs with the nvidia driver so I went for the generic vesa driver. I am thus useless regarding use of the 'nvidia-xorgconfig. Here I will suggest that the generic vesa driver may be an out, if all else fails.

    2) It is my understanding that while you have 4 different sets of color depths the system will respond only to the last one it sees. Also while you have 3-4 different screen resolutions per color depth, it is accepting the first resolution as the one you want. Hence you should be seeing 1280x1024 and 32 bit color. Unless you comment one of those 2 it is unlikely you have affected anything. U may be best off to experiment a little here.
    You state you added 1280x1024 to other color depths. Be very cautious because if this is outside the capability of your video tube you could possibly cause serious damage if it is used. At least that is what is pounded on quite frequently but what effect it has on LCD screens is not known to me. BTW check you owners manual regarding low/high frequencies both vertical and horizontal. These MUST be followed ABSOLUTELY (if using a CRT type tube, don't know about LCD).

    If I were in your boots, here is what I'd do:
    a) check the owners manual for screen capabilities and make sure that is what is displayed in the xorg.conf file.
    b) set aside the nvidia driver and try the generic vesa driver. If there is no improvement drop back to what suits you. BTW did u google the Nvidia driver that should've been interesting. There should be some hints there.

    My response to my problem was a script. I cut the xorg.conf file into beginning, end, color depth, and resolution. The color depth for you would be 8, 16, 24 and 32, each in its own file. Resolution would be 1280x1024, 1024x768, 800x600, 640x480 each in it own file. The script I wrote asks which color depth I want then which resolution I want. Note for you, you need to be sure that color depth 8 cannot be used with 1280x1024. The script copies the beginning file, selected color depth file, selected resolution file and the ending file segments together in order into xorg.conf. This way you can logout of the xwindo manager then rerun the script and try another combination of resolution and color depth.
    If this appeals to u and u r satisfied, add a section on selecting one of the window managers from xinit (xinitrc.winmgrnam) or mwm (system.mwmrc) and copy it to your home directory's xinitrc then when its all done have it startx.
    This probably does not make you really happy but it gives you a way to examine which driver to use, and to examine the color depth and resolutions very easily.
    Hope this helps. My script makes me giddy every time I use it <);^)

    BTW I gave up on jumping between resolutions with ctrl/alt/ sequences. Using the script the image shrink very little if at all.

  7. #7
    Linux Newbie
    Join Date
    Aug 2004
    Location
    Malvern, UK
    Posts
    132
    Thanks Clickit,

    You have solved the issue in a round about way

    I run 'xorgsetup', made changes where appropriate in the curses menu and then restarted 'X' using 'startx'.

    The end result is my xfce display is 1280x1024, nice and sharp and still using the nvidia drivers so I have glx etc and I can now ctrl alt f* to a terminal when I need to.

    Thanks for sticking with it and providing such a broad and comprehensive reply which has helped me to resolve the issue.

    Bubo
    My Computer Once Beat Me at Chess, but it is No Match for Me at Kickboxing !

    Registered Linux User: #417183

  8. #8
    Linux User
    Join Date
    Mar 2008
    Posts
    287
    Glad I could help even if a bit round about. Sometimes that's what it takes. You give me thought to re-consider nvidia driver.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •