If there has been another post on this, I apologize, but I searched to no avail.

I'm running Slackware 12.0, so it has proftpd pre-installed. When I try to run it using this:

$ /usr/sbin/proftpd

I get this:

- IPv6 getaddrinfo 'MyHost' error: Name or service not known

Now, I've googled this and come up with quite a few results, none of which helped. One said to disable IPv6 by putting in the "blacklist" file in /etc/modprobe.d. So I disabled it and got this error when I tried again:

- IPv4 getaddrinfo 'MyHost' error: Name or service not known
- warning: unable to determine IP address of 'MyHost'
- error: no valid servers configured
- Fatal: error processing configuration file '/etc/proftpd.conf'

Another result said to edit the /etc/hosts file to display this:

::1 localhost my.do.main MyHost

Which I did, and still no luck. I've tried starting the server both as a user and as root. This is really bugging me because I need that FTP server, so any help is greatly appreciated. Thanks in advance!

EDIT!!!!!!
I fixed it! I made a really stupid mistake. See, when editing the /etc/hosts file, I wiped all the hosts out of it and had ONLY

::1 localhost my.do.main MyHost

So I tried adding this below it:

127.0.0.1 localhost
XXX.XXX.XXX.XXX my.do.main MyHost

And it worked!