Find the answer to your Linux question:
Results 1 to 8 of 8
hi, I'm a complete noob when it comes to linux, so please avoid asking me the most complex of questions. All i know is. I have a 20gig hard drive ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2008
    Posts
    4

    [SOLVED] Complete Newb- a few questions, urgent help please.


    hi,

    I'm a complete noob when it comes to linux, so please avoid asking me the most complex of questions.

    All i know is.

    I have a 20gig hard drive with Linux 12 on it. I also have my old windows hard drive which is 500g which i have sucessfully mounted, and I wish to recover the data off it and put onto another hard drive to be accessed when i reinstall windows (XP). The other hard drive i'm talking about is a USB external hard drive 100g.

    i have managed to mount the external hard drive but it always says i don't have write permission. And to make things worse, my father disonnected it, so now its no longer mounted, but there are still files that were created from making it, in the root directory (/mnt/backup)?

    How can I mount it again, under a new file name or whatever, and be able to write to it, while being able to be later accessed by windows.
    I don't mind if there are pointless folders made in the process, i'm only bent on recovering my data from the old windows drive.

    Thanks if you can make any sense of this.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    What error message does mount command throw when try to mount partitions of External disk?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined! javilin93's Avatar
    Join Date
    Jun 2008
    Location
    Atlanta
    Posts
    36
    Hello
    First to mount the drive
    Code:
    sudo mount /dev/hdb2 /mnt/backup
    /dev/hdb2 being the partition you want to mount to backup
    next mount the other drive to another directory(the same way)
    Next
    Code:
    sudo thunar
    and now you should have the permissions to copy

  4. #4
    Just Joined!
    Join Date
    Jul 2008
    Posts
    4
    i've sucessfully mounted both the 500g windows NTFS drive, and the external 100g gig hard drive. Though im still having problems copying over.

    The windows drive is entirely windows, no linux partition on it at all.
    The hard drive is empty.

    The Windows Hard drive is mounted as /mnt/XP- this drive is Sata btw
    The external drive is mounted as /mnt/xpbackup- this drive is USB.

    when i mounted them i mounted the XP one as /dev/sda1 /mnt/XP
    and the external as /dev/sdb1 /mnt/xpbackup

    i created the folders earlier.

    I'm just throwing all this info
    Is there a simple way i can just overide the permissions.

    THanks again

  5. #5
    Just Joined!
    Join Date
    Jul 2008
    Posts
    4
    all i want to be able to do is to just drag and drop files i want from the 500g hard drive(sata internal) to the external 100g (usb) one.

    if that makes my goal seem any more simple.

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Execute this
    Code:
    mount -t ntfs-3g /dev/sdb1 /mnt/xpbackup -o defaults,umask=0
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Just Joined!
    Join Date
    Jul 2008
    Posts
    4
    cheers all but i got it solved,

    I reformatted the external HD with FAT32, and when i mounted it again, it worked perfectly and i've already transferred all my data.

    Sometimes the most simple way is the best :S, just wish i had remembered linux likes fat32 more then ntfs.

    thanks all

  8. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Linux support NTFS write access too and a few distros support write access out of box. Its very easy to enable ntfs write access in other distros. Install ntfs-3g package to enable NTFS read/write access.

    Anyways, glad to know that your problem has been sorted out. Do start a new thread if you have any other question.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •