Find the answer to your Linux question:
Results 1 to 8 of 8
Hey, I'm new to slackware but not *so* new to Linux (using it as main OS fo a year or so). Anyway, I've booted up slack and feel like connecting ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2008
    Posts
    3

    can recognize wireless card but cant connect to internet...


    Hey, I'm new to slackware but not *so* new to Linux (using it as main OS fo a year or so). Anyway, I've booted up slack and feel like connecting to my wireless, so I ran kwifimanager to scan for networks. Mine came up, I entered the WEP, and I got little green bars and happy messages galore. However, when I try opening up a browser (firefox, konqueror, even links)I fail to connect. Right now I have a Dell Inspirion 6000, which has a Intel PRO/Wireless 2200BG card. Iwconfig shows that the computer has recognized my card, and even that it has sucessfully connected. What's going on here?

    Thanks for any help.

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,132
    What do you have in /etc/resolv.conf? Can you ping from the terminal
    Code:
    ping linuxforums.org
    dig linuxforums.org

  3. #3
    Just Joined!
    Join Date
    Jul 2008
    Posts
    3
    I can't ping anything, and all that's in resolv.conf is search (username).

  4. #4
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    And if you try to connect manually?

    See the device:
    Code:
    ifconfig
    See the available networks:
    Code:
    iwlist scan
    If all seems well, try to get an IP
    Code:
    dhcpcd $interface        # Where $interface is something like wlan0 or eth1
    Are ESSID and WEP set correctly?
    Can you ping your router/modem? (probably 192.168.0.254 or 192.168.1.254 or something similar)
    Can't tell an OS by it's GUI

  5. #5
    Just Joined!
    Join Date
    Jul 2008
    Posts
    3
    Thanks Freston! I think the solve was dhcpcd. My only question is, will I have to do this every time I log in? Because I think I'll make a script if that's the case.

  6. #6
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    The Hot Humid South
    Posts
    602
    Have you editted /etc/rc.d/rc.inet1.conf and /etc/rc.d/rc.wireless.conf? You'll need to edit the first one to include any interfaces that aren't eth* and the second for wireless. If your only problem was dhcpcd you'll need to edit only the rc.inet1.conf. You'll need to set it to use dhcp, I can't remember what the variable is called but should be pretty obvious... set it to "yes".
    "Today you are freer than ever to do what you want, provided you can pay for it!" --Bad Religion

  7. #7
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    Quote Originally Posted by snappyjack
    Thanks Freston! I think the solve was dhcpcd. My only question is, will I have to do this every time I log in? Because I think I'll make a script if that's the case.


    I never really made an effort to automating wireless during boot. But it is certainly possible. You might want to look into your /etc/rc.d/rc.inet* scripts, 'cuz that's where it happens

    If you go for the manual approach, I don't think you'll need something elaborate as a script, you could just as well define an alias. And you can also put relatively complex commands in your KMenu, things like:
    Code:
    command1 options other_stuff && command2 more_options || alt.command
    And specify to run them as other user (root in this case). You'll be missing any output unless you also specify to run in terminal. But it's an ideal solution for relatively long and/or complex commands that you need to issue with any regularity.
    Can't tell an OS by it's GUI

  8. #8
    Just Joined!
    Join Date
    Apr 2009
    Posts
    33
    I suggest first that you find out your wireless interface by
    looking at the contents of /proc/net/wireless:

    cat /proc/net/wireless

    with my card (intel wireless 5100) and slackware my interface is wlan0

    so let's assume that's your interface too

    the next step would to bring that interface by typing in

    ifconfig wlan0

    then you check the available networks:

    iwlist wlan0 scanning | less

    (I use free hot spots at public libraries so I usually check the one
    that seem likely to be the local hotspot)

    when you have made your selection, get the info from the
    line
    ESSID:"...."

    connect your card to that essid (that's the string between the
    double quotes):

    iwconfig wlan0 essid "the_essid_you_read_above"

    next (and final) step:

    dhcpcd -t 30 wlan0

    now, hopefully you should be connected
    by the way, you need to be root to do this

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •