Hello, and thanks for taking the time to read this post. Unfortunately, I am COMPLETELY new to Linux. Right now I am just trying to transfer my website to my server here... Now, this being said I have followed instructions I was given by a friend to the letter and I do get the IT WORKS! when I type in my IP address. However, how the heck do I change it.

What I would like to do is post exactly what I have done in hopes that someone can tell me -- exactly -- what to type at the root prompt that will point my server to MY index file and not the default one.

Your assistance is greatly appreciated. The instructions are a bit long so please bare with me. It is the only way I know to possibly give you all the info you will need...

Boot from DVD

1 When the ISOLINUX screen comes up, you should be able to simply press enter. if
you get an error, reboot, type: huge.s (at the prompt press enter)
2. When asked for a keyboard map or something of the sort, press enter (twice)
3. You should be at a prompt ending in a # sign. If not, figure out what went wrong

4. time to wipe your hard drive or atleast enough to tell it it's wiped. type the following:
dd if=/dev/zero of=/dev/hda bs=1024 count=2048
then press enter. You should see something about records out/in Two lines if no
errors proceed.
5 Type cfdisk /dev/hda
You may be asked a question if so type y and press enter.
6 An interface will showup. It should show "Free Space" the size the drive on a line. If
it says NTFS or FAT32, use the arrows to select them and press the "delete" button.
7 Highlight "New" and press enter.
Choose "Beginning" and "Primary" when asked
8 When asked for a size, in MB, a value will be shown subtract 2000 from what it shows
(you'll have to type the new value) and hit enter.
9. You should have Linux and Free space now showing. Highlight the Linux one and highlight
"bootable" and press enter so a "B" or "Boot" shows on that line.
10 Go down to the free space and repeat steps 7 and 8 except just leave the size as it says this
11 Highlight the smaller partition, then highling "Type" and press enter several times until
you end up back at the list of commands. That line should now say "Linux Swap"
12. Assuming all is well highlight "Write" and press enter Type "yes" and press enter. When
it's done goto "quit"and press enter.
13. Back at the # prompt, type "setup" and press enter.
14. Scroll to "ADDSWAP" and hit enter. Enter 3 times... wait for it to finish.
15 Press enter 4x should be formatting hda1 in ext3 or so now wait...
16 Press enter 3x... wait for it to find the CD
17 Enter 2x... wait for everything to install.
18 Choose to skip making a USB stick
19 No Modem
20 Choose simple LILO
21 Choose the last option 1024 x 768 x 64k
22 Press enter when asked what to append to the kernel
23 Chose MBR wait...
24 Choose PS2 mouse
25 Choose yes to load at boot.
26 Yes, configure network
27 in the hostname box type vfi1 and press enter
28 For domain, type voiceforinmates.com press enter
29. Choose Static IP
30 Enter one of your open IP's (got it) and press enter.
31 enter your netmask should be 255.255255.0.....
32 Enter your gateway address....
33 Yes to nameserver
34 Enter your ISP's nameserver IP ( *** now I am assuming he means primary DNS)
35. Press Accept
36 in the list (enable) the following (using the space bar)
rc.bind, rc.cups, rc.httpd, rc.inetd, rc.messagebus, rc. mysqld, rc.sendmail, rc.syslog,
rc.sshd. Disable rc.pcmcia press enter
37 No custom fonts
38 No hardware clock is st to local time
39 US / Eastern
40 xinitre.kde
41 Yes, set root password. Follow instructions for setting a password.
47 Done. Pres enter got to exit remove cd reboot

Now, if all went well. You now have a linux machine running. You should be able to
goto http://ipaddres you gave and see "IT WORKS!" come up, to show that the
server well, is working..

However it's pretty stripped and does nothing yet. Let's get you basic access to hosting
so that you can (right now) start hosting files locally. Not the whole site yet, because
that'll require DNS setups and such...

So, on your scren should be a bunch of text, probably an error from mysql. Hit enter a
couple of times you should see vfi1 login: type root and press enter.
You should have a randome "fortune" followed by root@vfi1# this is where the fun

Type adduser (oneword). press enter
Type VFI for username press enter press enter for everything until you are asked
for a password. (not the same as root)

When you get back to the # prompt type
chmod 755 /home/vfi (press enter)
su vfi (press enter)
mkdir /home/vfi/www (press enter)
exit (press enter)
cd /var/lib/htdocs (press enter)
ln -s /home/vfi/www ./vfi (press enter)

ok after all that you should be able to ftp your machine..

Now, I had to pico /etc/inetd.conf and remove the # sign from the front of the proftpd
Then ctrl x, y, enter

Then type killall -HUP inetd (press enter)
/etc/rc.d/rc.inetd restart (press enter)


Again, I follewed this to the letter due to the fact that I just do not know the terms Linux uses... Thank You for taking the time to read this.