Find the answer to your Linux question:
Results 1 to 5 of 5
Please Help i resently installed Slackware 12.1 I configured 3 partitions. one for root, one for files serving and the swap partion. I let the install cd configure lilo automatically. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    3

    [SOLVED] New Install not booting


    Please Help i resently installed Slackware 12.1 I configured 3 partitions. one for root, one for files serving and the swap partion. I let the install cd configure lilo automatically. on the root partion. how ever when trying to boot the system hangs at boot from cd even though that option is disable in the bios. can anyone help?

  2. #2
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    Welcome to the forums!

    Problems in your Master Boot Record? Did you toggle the 'boot' flag for your root partition when you partitioned?

    If you boot up from the install CD#1/DVD at the prompt, type this:
    Code:
    fdisk -l        # the l is a small L, not an 1(one)
    See if your first partition is bootable.

    I believe that, if it's not, the GParted liveCD can help setting the boot flag. Although, I hate to say this, a reinstall is probably quicker. That is... if the problem is the boot flag.
    Can't tell an OS by it's GUI

  3. #3
    Just Joined!
    Join Date
    Sep 2008
    Posts
    73
    In addition to what Freston said, using cfdisk tends to be more new user friendly.

    Also, I've not had much luck allowing the installer to install LILO automatically.
    The 'expert' install for LILO really isn't too difficult and it allows you more control.
    As it explains, you create a new header file(the installer actually does this for you, you just need to select the menu option), then add partitions making sure you have your root partition bootable.
    Then install LILO to the superblock of the / partition.
    No sweat.
    Even if you make a mistake, you just start over by choosing the 'begin' menu option.

  4. #4
    Just Joined!
    Join Date
    Sep 2008
    Posts
    3
    Thanks ill give your sugestions a shot tomorrow

  5. #5
    Just Joined!
    Join Date
    Sep 2008
    Posts
    3
    Hey thinks for the info I ended up doing a complete install the same as i had before, but this time I did the expert install of lilo and everything worked great

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •