Find the answer to your Linux question:
Results 1 to 7 of 7
What the hell does it mean when the screen fills up like this:: L 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    73

    [solved] l 99 99 99 99 99 99


    What the hell does it mean when the screen fills up like this::

    L 99 99 99 99 99 99 99 99 99 99 99 99
    99 99 99 99 99 99 99 99 99 99 99 99 99......

    I setup a dual boot Slack/XP machine and at boot that's what I get.

    Never seen it before in my life.

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Where on the system did you install LILO?

    Try again, but install it to the MBR if you didn't do so the first time.
    oz

  3. #3
    Just Joined!
    Join Date
    Sep 2008
    Posts
    73
    I wiped out both drives.
    Screw Windows!
    I hate windows so much I'd like to bodyslam Willie-G onto one of those 'SurfacePC' tables.
    Unfortunately though I need to have a decent windows box that can run a couple apps that either don't have Mac ports or are cost prohibitive.

    Anyway-
    The system I'm having the problem with has these specs::
    800MHz P3
    512MB RAM
    2-20GB IDE drives.
    Toshiba DVD-ROM.
    Drive1 has the / partition in ext3 made bootable.
    Drive2 has a 1024MB swap and a "/usr/local" partition.

    I used the expert mode to generate the LILO.conf.
    Everything was as expected during install, LILO installed with no problems.
    But I get the above jargon screen still.
    Even though I wiped everything out since I first got the error screen.

    It makes sense that I got it when the machine was dual booted since I didn't use MBR.
    I have another system that's configured in the same way and it has no issues.

  4. #4
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    What you have there is probably some confusion in LILO about which disk needs to be /


    Code:
    When the first
           stage loader gets control, it types the letter "L"; when it is ready to transfer control to the second  stage  loader
           it  types the letter "I".  If any error occurs, like a disk read error, it will put out a hexadecimil error code, and
           then it will re-try the operation.  All hex error codes are BIOS return values, except for the lilo-generated 40,  99
           and 9A.  A partial list of error codes follows:
    
                  00  no error
                  01  invalid disk command
                  02  address mark not found
                  03  disk write-protected
                  04  sector not found
                  06  floppy disk removed
                  08  DMA overrun
                  0A  bad sector flag
                  0B  bad track flag
                  20  controller failure
                  40  seek failure (BIOS)
                  40  cylinder>1023 (LILO)
                  99  invalid second stage index sector (LILO)
                  9A  no second stage loader signature (LILO)
    Can you port the output of this command:
    Code:
    fdisk -l      # Where l is a small L, not a 1(one)
    And we need the contents of /etc/lilo.conf:
    Code:
    cat /etc/lilo.conf
    For this you need to mount your / partition. You can do all this from the install media you have.
    Can't tell an OS by it's GUI

  5. #5
    Just Joined!
    Join Date
    Oct 2008
    Posts
    44

    Talking

    I don't know if this will be any help or not, but I've been using Partition Magic for years now to dual-boot Win and Lin with only a few problems. I have NEVER, nor will I EVER install LILO or GRUB on the MBR of a Windows disk. It might work for some, or even most people, but I'm satisfied with BootMagic and the way it loads each OS without either having to know about the other. The trick is to load PM and BM in Windows, then set up your Slack part(s) and load it up oblivious to any Win installs. I made the VERY bad mistake of letting Slack take care of the Linux part (= partition, the typing-ugh), and it reset my disk to an architecture that PM wouldn't deal with at all. It kinda P*ed me off, but I went straight back to Win and deleted all the ext and swap parts through PM. It then straightened the disk back out, and I proceeded to re-create the swap and main / parts with PM. Once I did that, I could resize the Win part and use the remaining space for the FULL Slack install! Right now, it's running like crazy on the old Pentium 120, and as soon as the install is finished, I completely expect to have a working dual-boot system with W98 and the latest SlackWare. I'll keep posted if any problems, but PM is the best way I'VE found to do a dual system. I'd NEVER write LILO to the boot sector unless it was a LINUX only machine. PM doesn't cost much, and if you are on a limited budget, well you can always get a copy SOMEHOW if you look hard enough!

  6. #6
    Just Joined!
    Join Date
    Sep 2008
    Posts
    73
    There's a copy of PM here somewhere.
    Don't remember where, or who owns it but I saw it a few months back.

    I'm not planning to do a dual boot anymore though.
    I'm just gonna set it up with Slack12 with the partition scheme I described above.
    There's something about dual boot configs that I'm not comfortable with.
    It makes me feel like the computer is fragile or half the man it used to be.
    Like a man with one ball.
    I know that's not the case, but I still get that impression.

    I have 3 old HP Vectra VL5 workstations to play with.
    The HP's have P11-266MHz, 512RAM, 3GB drives in each of them.
    Courtesy of a company I do freelance work for.

    The strange thing there is that I haven't been able to get Slack up and running on any of those HP's.
    Tried it every way I can think of, tweaked everything I can, and everytime it says "error loading operating system">
    They take XP just fine, but they won't take Slack.
    Gonna try Fedora on one and see what happens.

    Situations like these remind me how much I love my PowerMac.

    I'm trying to setup a DMZ here in order to expand my knowledge of Linux security.
    So I'm gonna go with DSL on one, Fedora on another.
    Other than that I'm unsure.
    And of course there's the Slack box to be used as my primary Linux machine, a slightly older Dell running XP because I need windows still to use my GPS and a few other apps.
    I want to mix it up a bit so I can get familiar with some of the more common distros and their strengths and weaknesses.

    I'd like to be able to get a tech support job with Linux and/or mixed environments where I can work primarily from my home.
    Then eventually pick up where I left off a couple years back learning to write code.

    I'll post the contents of those files later on when I'm home for the night.
    Thanks for the replies...

  7. #7
    Just Joined!
    Join Date
    Sep 2008
    Posts
    73

    Solved...

    Problem solved...

    I added an old CDR-RW drive just in case the DVD-ROM was having problems again.
    Then replaced the lone 128MB memory module with a 256.
    Giving the system 768MB total.
    I replaced the boot drive, and put the swap on the same drive.
    Used the 2ndary drive as /usr/local, then installed Slack10.2.

    During the usual install routine, the system got extremely loud.
    It was either the CPU fan or the power supply fan.
    So I replaced the CPU fan with one that has dual fans on it, and put a 450W power supply in.

    Now it's going strong with no issues.
    I'm on to get these 3 HP's up.

    I got "elpicx" live DVD, hopefully it will run in a VM on my Mac in order to get started with the LPI.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •