Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
I just did a fresh Slackware install on my new machine, and everything went smoothly. At first, xorg (in any window manager) wouldn't respond to my wireless mouse at all. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    May 2004
    Location
    Boston, MA
    Posts
    246

    Mouse buttons don't work in xorg


    I just did a fresh Slackware install on my new machine, and everything went smoothly. At first, xorg (in any window manager) wouldn't respond to my wireless mouse at all. However I fixed that by synching the mouse to the receiver. Now the mouse pointer moves when I move the mouse, but the buttons don't do anything when I click them. Is anybody familiar with this issue?
    Situations arise because of the weather,
    And no kinds of love are better than others.

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    No buttons work? What type of mouse is it (brand, interface,buttons)? And can you post the mouse section of you xorg.conf?
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Linux Newbie
    Join Date
    May 2004
    Location
    Boston, MA
    Posts
    246
    No, none of my mouse buttons work. Here's my xorg mouse section:
    Code:
    Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "Auto"
    Option "Device" "/dev/mouse"
    EndSection
    It's a Memorex wireless RF7000 wireless optical mouse. Thanks for responding. Any ideas?
    Situations arise because of the weather,
    And no kinds of love are better than others.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
    Option "Device" "/dev/mouse"
    Option "Protocol" "PS/2"
    Option "Emulate3Buttons" "off"
    Option "ZaxisMapping" "4 5"
    EndSection

    Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "IMPS/2"
    Option "Emulate3Buttons" "off"
    Option "ZAxisMapping" "4 5"
    EndSection

    Mike looks like this.

  6. #5
    Linux Newbie
    Join Date
    May 2004
    Location
    Boston, MA
    Posts
    246
    Thanks.

    I tried copying both those examples, but still the same problem; I can move the mouse around the screen, but can't click. I know that the click signal is at least making it to the wireless receiver, because that blinks whenever I click. Also, my keyboard is connected to the same receiver and works fine. Anybody have any different approaches?

  7. #6
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    I have a lazor mouse and it works. I don't have a wireless so I can't be much help. I do however suggest that if you figure it out that you post it, because I am sure that it will come up again somewhere else. Also save your origional
    xorg file as something else and experiment with the options see if you can accidentally figure it out. If it breaks you can always overwrite your experiment with your saved file


    Keep us informed,
    Mike

  8. #7
    Just Joined! mont's Avatar
    Join Date
    Jul 2004
    Posts
    10
    In Slackware 10 my mouse works ok with exception of the wheel function.

    Don't have that problem with Fedora, SuSe etc.

    Any Ideas please?

  9. #8
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    Ya scroll up a couple and compare your xorg.conf file to mine.
    You need the right protocoll PS/2 or IMPS/2 and don't forget the ZAxismapping option
    Mike

  10. #9
    Just Joined! mont's Avatar
    Join Date
    Jul 2004
    Posts
    10
    Thanks for the reply. I did read your post and edit my config file to correspond with your suggestion, before posting, and it had no effect

    I suppose it's no big deal but it is a handy facility.

  11. #10
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    Show me your xorg.conf file.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •