Find the answer to your Linux question:
Results 1 to 8 of 8
I recently made the switch to linux, running Slackware 12.1, and I've been pretty comfortable with it other than the wireless My comp is a Toshiba Satellite A215-S4757 and uses ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2008
    Posts
    3

    Laptop Wireless issues


    I recently made the switch to linux, running Slackware 12.1, and I've been pretty comfortable with it other than the wireless
    My comp is a Toshiba Satellite A215-S4757 and uses Atheros AR242x 802.11abg

    I've read that this chipset is supported by Madwifi, but after countless tries I got nothing.I also tried Ndiswrapper but again, nothing

    Also, for some reason the wireless did work with Ubuntu Eee, but I would much prefer to get it running on Slackware

    I'm a bit of newbie, as I am sure you can tell, so I am asking for any info or advice on how to get it running

    I'm sorry if I have not posted enough info, I will try and find out more if need be

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I have this wireless in my Eee Pc 900. It is now supported by the ath5k driver. This driver is in newer kernels, and nothing else needs to be installed.

    I installed Fedora 10, and it worked out-of-the-box. I also use NetworkManager to connect to wireless networks. Here is the kernel version that I have:

    2.6.27.7-134.fc10.i686

    The driver can be installed as part of the Linux Wireless compat-wireless-2.6 package.

    Download - Linux Wireless

    If you must use the Madwifi driver, you will need to compile the Subversion version.

    I understand that NetworkManager is not available for Slackware. That is a shame, as it makes connecting to wireless networks very easy. I would not use Slackware for wireless because of this. NetworkManager is available in Fedora, Suse and Ubuntu, and I'm sure others too.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    Dec 2008
    Posts
    3
    Victory!

    thx waterhead, the ath5k driver seemed to have worked without a problem, now I just have to figure out how to connect to a network
    Im going to stick with Slackware tho simply because I'm trying to learn as much as I can about Linux and doing things the easy way would only hinder that

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    You may need some help from someone with Slackware experience.

    There are two things that you should install. There is a wireless-tools package, that provides many of the terminal commands for wireless. And then there is wpa_supplicant, for connecting to WPA encrypted connections.

    The names of these may be slightly different in Slackware.
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #5
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    It's not very diffcult to run wireless on Slackware without any form of network manager. You just need to know how.

    There are some automagic approaches possible, look in the /etc/rc.d directory for that. But I never completely figured it out that way, to be tell you the truth. Connecting manually is so much easier. And a script is just a `vim` away

    Code:
    # Bring up the interface 1)
    ifconfig wlan0 up
    
    # optionally, just checking whether you can see your access point
    iwlist scan 
    
    # Asociate 2) with an Access Point
    iwconfig wlan0 essid $YOUR_ESSID
    
    # Request IP address, gateway and nameserver
    dhcpcd wlan0
    If this works, then you can enable encryption and use iwconfig to add your key to the process.





    1) It may be that your interface name isn't wlan0, it might be ath0. You can check with
    Code:
    ifconfig -a
    2) Sorry, no spelling checker installed on this browser
    Can't tell an OS by it's GUI

  7. #6
    Just Joined!
    Join Date
    Apr 2009
    Posts
    33

    a few corrections

    Basically I agree with the first post (Freston), except that it needs a
    few corrections

    #this one is ok
    # Bring up the interface 1)
    ifconfig wlan0 up

    #this one is wrong. I wrote below the correct command
    # optionally, just checking whether you can see your access point
    iwlist scan
    #corrected
    iwlist wlan0 scanning

    # Asociate 2) with an Access Point
    iwconfig wlan0 essid $YOUR_ESSID

    # Request IP address, gateway and nameserver
    dhcpcd wlan0

  8. #7
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    #this one is wrong. I wrote below the correct command
    # optionally, just checking whether you can see your access point
    iwlist scan
    #corrected
    iwlist wlan0 scanning
    Both scan and scanning work for me. However, if you use WPA encryption on your wireless network, which you should, since WEP is weak, this method won't work, you'd need to configure wpa_supplicant.

  9. #8
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I have since found that you can install Wicd in Slackware, and use that. It uses wpa_supplicant for WPA connections.

    wicd - home
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •