Find the answer to your Linux question:
Results 1 to 5 of 5
Hello. I am running Slackware 12.2 here. I am ripping cd's with k3b. They rip to my /home/ directory. I am trying to move them to my USB drive. 99% ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2008
    Posts
    15

    [SOLVED] konqueror/thundar/dolphion cannot move file


    Hello.

    I am running Slackware 12.2 here.
    I am ripping cd's with k3b.
    They rip to my /home/ directory.
    I am trying to move them to my USB drive.
    99% of the files will move.
    Occasionally, 1 of the ripped files from the cd will not be able to moved
    Konqueror says "Could not write xxxxxxx"
    Thundar says "Failed to open "/media/Elements/music new rip/311/Grassroots/04 - 8:16 AM.mp3" for writing (Invalid argument)."
    Dolphin says: Could not write xxxxxx"

    This file (and some others) cannot be moved. Interestingly, if i re-rip the song, it still cannot be moved.

    I noticed the file owner ship of the ones that cannot be moved differ from the ones that can
    cannot be moved: user kilbert group : users.

    can be moved shows permissions: user kilbert group root

    so i chgrp the file to root, but the files still cannot be moved.

    any help is appreciated.
    thanks

  2. #2
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    It could be the name of the file that is causing the error. Try changing the name to something without a semicolon to see if that helps.

    Also, try from the command line to see if the error message is any more instructive.
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  3. #3
    Just Joined!
    Join Date
    Dec 2008
    Posts
    15
    Tried renaming the file, it did not help. Thanks for trying.

  4. #4
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    USB-drives are often FAT16 or FAT32 formatted. And that can give problems sometimes when it comes to file names and sizes. I notice spaces in the file name for example.

    Try renaming the file to 'testfile' or something equally unprovocative and try again to copy it.
    Can't tell an OS by it's GUI

  5. #5
    Just Joined!
    Join Date
    Dec 2008
    Posts
    15
    I stand corrected, seems to be an issue with naming of the file, as I am a complete noob (<30 days on linux) I have a lot to learn.
    The files can now be moved.
    Thanks smolloy and freston.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •