Find the answer to your Linux question:
Results 1 to 5 of 5
I have a problem getting into KDE with startx. I mispelled startx when trying to get to KDE and this messed things up. Now startx doesn't work. I copied a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Dec 2008
    Posts
    163

    Problem with startx


    I have a problem getting into KDE with startx.
    I mispelled startx when trying to get to KDE and this messed things up.
    Now startx doesn't work.
    I copied a .xinitrc from /root into my home directory. This didn't solve the
    problem.

    Would appreciate help with this.

    Thanks.

  2. #2
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    ???? A misspelling shouldn't lead to problems like you say (unless you accidentally typed rm `which startx` )

    What does this say?
    (after startx errors out)
    Code:
    cat ~/.xsession-errors
    Does switching to runlevel 4 work?
    (as root)
    Code:
    telinit 4
    Can't tell an OS by it's GUI

  3. #3
    Linux Newbie
    Join Date
    Dec 2008
    Posts
    163
    cat ~/.xsession-errors
    I can't find that file in my home directory
    This is ~/.xsession. Hope it's helpful.
    # This program, based on code found in the gpg-agent man page, is
    # presumably licensed under the GPL.
    #
    # As the effects of this default .xsession on an account using
    # (t)csh are not yet known, feedback and/or suggestions are welcomed.

    if [ -x "$(which gpg-agent)" ]; then
    if test -f $HOME/.gpg-agent-info && kill -0 $(cut -d: -f 2 $HOME/.gpg-agent-info) 2>/dev/null; then
    GPG_AGENT_INFO=$(cat $HOME/.gpg-agent-info)
    export GPG_AGENT_INFO
    else
    eval $(gpg-agent --daemon)
    echo $GPG_AGENT_INFO >$HOME/.gpg-agent-info
    fi
    fi

    # Note that the new option --write-env-file may be used instead.

    # You should always add the following lines to your .bashrc or whatever
    # initialization file is used for all shell invocations:

    GPG_TTY=$(tty)
    export GPG_TTY
    Does switching to runlevel 4 work?
    (as root)
    As root I can get into KDE with telinit 4
    also I can use startx to get into KDE,
    but not as a user.

    Thanks.

  4. #4
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    Well, it would obviously be helpful if you say what the error is that you are receiving. And/or what the typo was that caused all this.

    But apart from that, one thing that comes to mind is that copying your .xinitrc from /root/ to /home/$USER messed things up permission wise. Did you `chown` that file to your user account?

    By the way, I don't have an .xinitrc on any accounts except root. .kderc and .xsession are all present and accounted for, but no .xinitrc.

    One thing you can do is type this as user:
    Code:
    startx 2> ~/errors
    And post the contents of your new file 'errors' here.
    Can't tell an OS by it's GUI

  5. #5
    Linux Newbie
    Join Date
    Dec 2008
    Posts
    163
    I found something that worked.

    I deleted the .Xauthority and .xsession files in my home dir.

    Now I am able to startx into KDE.

    There must have been something wrong with one or both of those files.

    This is the .Xsession file if anyone is interested:

    ^A^@^@^Hdarkstar^@^A0^@^RMIT-MAGIC-COOKIE-1^@^P `Ī-w R^PrM^N~EUi^A^@^@^ESlack^@^A0^@^RMIT-MAGIC-COOKIE-1^@^Pį~W~I:ń^C^F^P$^["^@^@^@^D^?^@^@^A^@^A0^@^RMIT-MAGIC-COOKIE-1^@^P^_^U~JNMJ0~[!| y
    darkstar was the name Slackware called me (joe@darkstar). I chose slack. Slackware
    later changed this.

    Thanks for help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •