Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, I am trying to install clam and klam frontend i Used slacky repositoru and installed clamav, and klamav frontend. it would not run from th eGUI, so i ran ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2008
    Posts
    15

    [SOLVED] Klam av


    Hi,
    I am trying to install clam and klam frontend

    i Used slacky repositoru and installed clamav, and klamav frontend.

    it would not run from th eGUI,

    so i ran from terminal and got the following error

    root@73:/home/kilbert# klamav
    klamav: error while loading shared libraries: libclamav.so.4: cannot open shared object file: No such file or directory

    I searched repos/google for libclam.so.4 and cannot find it. I also tried reinstall.


    Any help is appreciated.

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Assuming clamav is indeed installed, it might just be that klamav is looking for that file in a place where it isn't. For instance, it might be looking for libclamav.so.4 in /usr when it's installed to /usr/lib. Another possibility is that it is specifially looking for libclamav.so.4 and what you actually have (as an eaxample) is libclamav.so.5. A symlink can be used for either problem. If the former, you could do (as examples):
    Code:
    ln -s /usr/lib/libclamav.so.4 /lib/libclamav.so.4
    If the later:
    Code:
    ln -s /usr/lib/libclamav.so.5 /usr/lib/libclamav.so.4
    Just trying to give you a few ideas. Hope this helps.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  3. #3
    Just Joined!
    Join Date
    Dec 2008
    Posts
    15
    Thasnks
    I performeda slocate libclamav and found that I had libclamav.so.5 not the .4
    So I performed the later command (ln -s /usr/lib/libclamav.so.5 /usr/lib/libclamav.so.4) as root

    got same error for libclamunrar_iface.so.4

    performed slocate and performed same logic as you taught me on the other files.
    (ln -s /usr/lib/libclamunrar_iface.so.5 /usr/lib/libclamunrar_iface.so.4)
    and
    (ln -s /usr/lib/libclamunrar.so.5 /usr/lib/libclamunrar.so.4)


    I ran klamav from command line and got an error theat said no protocol specified, so I ran from the GUI and it works!

    The reason I posted so much was to
    1) thansk you and
    2) close this thread so if someone else stumbles on it this post can hopefully help them.
    thanks Dapper Dan
    kilbert

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •