Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15
Try # ifconfig wifi0 up or #if config ath0 up...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Jan 2009
    Posts
    3

    Try
    # ifconfig wifi0 up
    or
    #if config ath0 up

  2. #12
    Just Joined!
    Join Date
    Jan 2009
    Posts
    7
    Still the same --

    # ifconfig wifi0 up
    wifi0: ERROR while getting interface flags: No such device
    # ifconfig ath0 up
    ath0: ERROR while getting interface flags: No such device


    This is so puzzling -- the harware is detected, the driver installed, but somehow I cannot seem to activate the wireless lan ...

    Thanks for your efforts,

    Stephan

  3. #13
    Just Joined!
    Join Date
    Apr 2009
    Posts
    33
    obviously you have not installed the last version of slackware
    (slackware12.2)
    I advise you to do so, because your wireless card (intel 3945) is
    supported and if you do
    ifconfig -a
    you should see wlan0

    I had the same wireless card on a laptop where I had installed
    a previous version of slackware
    I had to rebuild the kernel and install the firmware in order to
    use my card
    Also the interface used to be called eth1
    It since a certain version of linux2.6 (I don't remember which)
    it's been changed to wlan0
    anyway, to see if the card is installed and to find out the interface
    name, you just
    # cat /proc/net/wireless

    and on the last line you should see its name (eth1 or wlan0)

  4. $spacer_open
    $spacer_close
  5. #14
    Linux User saivin's Avatar
    Join Date
    Dec 2008
    Location
    Bengaluru, India
    Posts
    305

    Check the physical wireless On/Off switch is ON or not

    Hi slender,
    First and foremost, have you turned ON your wireless? I mean physically turning on the switch, not through 'ifconfig wlan0 up'.

    It may look silly but many a time I have done this myself, keeping the wireless/bluetooth turned off and trying to connect wireless.

    Just cross check.
    A candle looses nothing by lighting other candles. - Khalil Zibran.
    Registered Linux User #490076

  6. #15
    Just Joined!
    Join Date
    Jan 2009
    Posts
    7
    The wlan is physically activated.

    What I ended up doing, re-installing the kernel, and the thing worked. No one really seems to know why this problem occurs, or how to fix it, but I'm happy that I can use the wireless.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •