Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Ive tried to change the wallpapers on 12.0 but is reverts after i restart. Which directory houses the images for wall paper and login etc . I want to put ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2006
    Posts
    27

    Wallpapers


    Ive tried to change the wallpapers on 12.0 but is reverts after i restart. Which directory houses the images for wall paper and login etc . I want to put some pics there, maybe they will remain as the wallpaper when i restart.

  2. #2
    Linux Newbie
    Join Date
    Feb 2009
    Location
    Third ring of Pergatory
    Posts
    199
    Which window manager do you use?

  3. #3
    Just Joined!
    Join Date
    Sep 2006
    Posts
    27
    Quote Originally Posted by dijetlo View Post
    Which window manager do you use?
    I use KDE. Also will i have to edit the inittab file

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Feb 2009
    Location
    Third ring of Pergatory
    Posts
    199
    Quote Originally Posted by ian4frost View Post
    I use KDE.
    You can use the KDE control center-> Appearence& Themes"
    or you can use "fbsetbg" or "wmsetbg" from the command line. Be sure to look at the manual page for both commands, There are some handy switches available to customize the way the window manager handles the background image for both

    Quote Originally Posted by ian4frost View Post
    Also will i have to edit the inittab file
    No, but if you do, make sure you make a back up of the original before you begin,
    Last edited by dijetlo; 03-20-2009 at 05:41 PM. Reason: User Error

  6. #5
    Just Joined!
    Join Date
    Sep 2006
    Posts
    27
    Quote Originally Posted by dijetlo View Post
    You can use the KDE control center-> Appearence& Themes"
    or you can use "fbsetbg" or "wmsetbg" from the command line. Be sure to look at the manual page for both commands, There are some handy switches available to customize the way the window manager handles the background image for both

    The problem is not changing the background. Its after i restart it reverts to one i had set priously which would be one of the default ones.

  7. #6
    Just Joined!
    Join Date
    Sep 2008
    Posts
    73
    The system is probably not saving your session.
    I'm not in slack right now so I can't tell you exactly where to find it.
    But there's a place to set your session prefs.
    You want the system to automatically save your session on logoff, then restore the previous session at login.

  8. #7
    Just Joined!
    Join Date
    Sep 2006
    Posts
    27
    Quote Originally Posted by glaston View Post
    The system is probably not saving your session.
    I'm not in slack right now so I can't tell you exactly where to find it.
    But there's a place to set your session prefs.
    You want the system to automatically save your session on logoff, then restore the previous session at login.
    Correct!
    I managed to get the wallpaper to stay, but you know when you boot to run level 4 and u are faced with the user/password prompt, thats the background i want to set to a specific image.

  9. #8
    Just Joined!
    Join Date
    Sep 2008
    Posts
    73
    That's the greeter.
    I believe you change the settings for that when you're actually at the greeter(login screen).
    There should be a button on that screen that gives you a menu when you click it.
    I think it's even called "session", but that might be in Debian:Gnome.
    Nevertheless, you change it in the greeter prefs.
    I keep thinking it's called GDM(gnome)/KDM(K desktop).
    I wish I could check it for you but unfortunately I'm having problems with my main slack box, and my other slack box is old and weak so it runs in console mode only.
    It's purpose is as a pseudo-DMZ server to ssh into it remotely from the web in order to access the rest of the machines on my network.

  10. #9
    Just Joined!
    Join Date
    Sep 2006
    Posts
    27
    Well i've tried everything. It cant be changed from that menue. Im out of ideas. googling none the less

  11. #10
    Just Joined!
    Join Date
    Sep 2008
    Posts
    73
    Open kde control center.
    All the way to the bottom in the administration category you can configure the login screen.
    Make sure you're root, or authenticate with the "administrator mode" option or it won't let you change anything.
    From there you can choose wallpaper just like you do with the actual desktop config.
    Again, make sure your session prefs are set to save/restore the session at login/off.

    There could be a configuration glitch or permissions conflict happening too.
    If all else fails you can manually edit the 'conf' file if you know what arguments you need to add.
    What groups are your user accounts configured for?
    User only?
    Or dev/cdrom etc?
    You might have to edit your account settings to make sure you have the right permissions set.
    But really you should be able to login as root and "chmod" it.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •