Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Hello all! I guess I could have put this under either the Laptop or the Peripherals sections, but to be honest, the only distro I'm seeing this in is in ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023

    Minor issue with Touchpad control on 12.2


    Hello all!

    I guess I could have put this under either the Laptop or the Peripherals sections, but to be honest, the only distro I'm seeing this in is in Slack.
    I'm running 12.2 on an Acer aspire 4730z. I'm getting along quite well with package installation, got wireless going (still looking into making it connect automatically... that's an ongoing project though)

    I'm just curious about the touchpad control. The pad works perfectly fine except for the little 'scrolling slider' on the side. I'm running Xfce 4.4.3 Here is the entire pertinent portion of my xorg file:
    Code:
    Section "InputDevice"
    
    # Identifier and driver
    
        Identifier	"Mouse1"
        Driver	"mouse"
    
    # On platforms where PnP mouse detection is supported the following
    # protocol setting can be used when using a newer PnP mouse:
    
    #    Option     "Protocol"      "Auto"
    
    # The available mouse protocols types that you can set below are:
    #    Auto BusMouse GlidePoint GlidePointPS/2 IntelliMouse IMPS/2
    #    Logitech Microsoft MMHitTab MMSeries Mouseman MouseManPlusPS/2
    #    MouseSystems NetMousePS/2 NetScrollPS/2 OSMouse PS/2 SysMouse
    #    ThinkingMouse ThinkingMousePS/2 Xqueue
        Option "Protocol"    "PS/2"
    
    # The mouse device.  The device is normally set to /dev/mouse,
    # which is usually a symbolic link to the real device.
    
        Option "Device"      "/dev/mouse"
    #   Option "Device"      "/dev/psaux"
    #   Option "Device"      "/dev/ttyS0"
    #   Option "Device"      "/dev/ttyS1"
    
    # When using XQUEUE, comment out the above two lines, and uncomment
    # the following line.
    
    #    Option "Protocol"	"Xqueue"
    
    # Baudrate and SampleRate are only for some Logitech mice. In
    # almost every case these lines should be omitted.
    
    #    Option "BaudRate"		"9600"
    #    Option "SampleRate"	"150"
    
    # Emulate3Buttons is an option for 2-button Microsoft mice
    # Emulate3Timeout is the timeout in milliseconds (default is 50ms)
    
    #    Option "Emulate3Buttons"
    #    Option "Emulate3Timeout"    "50"
    
    # ChordMiddle is an option for some 3-button Logitech mice
    
    #    Option "ChordMiddle"
    
    EndSection
    
    # Some examples of extended input devices
    
    # Section "InputDevice"
    #    Identifier "spaceball"
    #    Driver     "magellan"
    #    Option     "Device"        "/dev/cua0"
    # EndSection
    #
    # Section "InputDevice"
    #    Identifier "spaceball2"
    #    Driver     "spaceorb"
    #    Option     "Device"        "/dev/cua0"
    # EndSection
    #
    # Section "InputDevice"
    #    Identifier "touchscreen0"
    #    Driver     "microtouch"
    #    Option     "Device"        "/dev/ttyS0"
    #    Option     "MinX"          "1412"
    #    Option     "MaxX"          "15184"
    #    Option     "MinY"          "15372"
    #    Option     "MaxY"          "1230"
    #    Option     "ScreenNumber"  "0"
    #    Option     "ReportingMode" "Scaled"
    #    Option     "ButtonNumber"  "1"
    #    Option     "SendCoreEvents"
    # EndSection
    #
    # Section "InputDevice"
    #    Identifier "touchscreen1"
    #    Driver     "elo2300"
    #    Option     "Device"        "/dev/ttyS0"
    #    Option     "MinX"          "231"
    #    Option     "MaxX"          "3868"
    #    Option     "MinY"          "3858"
    #    Option     "MaxY"          "272"
    #    Option     "ScreenNumber"  "0"
    #    Option     "ReportingMode" "Scaled"
    #    Option     "ButtonThreshold"       "17"
    #    Option     "ButtonNumber"  "1"
    #    Option     "SendCoreEvents"
    # EndSection
    I know this has got to be a fairly easy fix... but I can't seem to find the solution.

    Thanks in advance folks!

    *EDIT*

    Well, at least I think I can cancel the part about starting wireless on startup! I edited my /etc/rc.local to start up, and -BINGO-!
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    What version of xorg-server are you using? Starting in the 1.5.xx series, input hotplugging is enabled by default, which means you have to either 1) turn it off or 2) configure your pad through HAL policies at /etc/hal/fdi/policy/.

    The Arch Linux Wiki on touchpads had some good info that should be applicable.

  3. #3
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Hi, reed!

    Code:
    xorg-server-1.4.2-i486-1
    I'll start looking over that link you posted.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie TrashOverride's Avatar
    Join Date
    May 2004
    Location
    @home...soon in your homes ;) /usr/src/bulgaria
    Posts
    162
    Same issue here. KDE 3.5.10 slack 12.2. I think it has something to do with X,Y end points of the mousepad.

  6. #5
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023

    Question

    I just had a thought... Is it possible that my entry is wrong for a mouse entry? I'm kinda lost cuz not only is it my first successful Slack install, but also the first lappy I've owned.
    Code:
        Identifier	"Mouse1"
        Driver	"mouse"
    Is there any other entry that would indicate a touchpad?
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  7. #6
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    Quote Originally Posted by jayd512
    I just had a thought... Is it possible that my entry is wrong for a mouse entry? I'm kinda lost cuz not only is it my first successful Slack install, but also the first lappy I've owned.
    Well, congratulations then!

    Slackware on a laptop is a good combo, but no doubt you have noticed installing Slackware is more manual than most other distro's. Anyway, here is my xorg.conf section:

    Code:
    # Nothing fancy, but scrolling works perfectly ;-)
    Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option      "Protocol" "auto"
    Option      "Device" "/dev/input/mice"
    Option      "ZAxisMapping" "4 5"
    EndSection
    This is on a notebook running Slackware 12.1.



    ___
    Note about Synaptic:
    But I seem to recall that a Synaptic touchpad (if applicable) requires loading extra drivers, due to a licensing incompatibility between X.org and Synaptic. A Synaptic touchpad without the extra driver works as you describe, it works but not the extra features like scrolling, dragging, and the likes. It's not that hard to get a Synaptic touchpad going, but it requires a little more than the above.
    So if you have one of those, try google or post here. It's been a while since my laptop with a Synaptic touchpad died so maybe the world has changed since then, but perhaps I or someone else can help


    EDIT:
    I just remembered, I still have my installation notes for my old lappy. Note that this was in the Slackware 12.0 era, but it might be of interest...
    Code:
    - Key   Add to /etc/X11/xorg.conf (section InputDevice; keyboard)
            <Option "XkbOptions" "compose:rwin">
    - Mouse Add to /etc/X11/xorg.conf:
            > InputDevice section
            Section "InputDevice"
                    Identifier      "Synaptics Touchpad"
                    Driver          "synaptics"
                    Option          "SendCoreEvents"        "true"
                    Option          "Device"                "/dev/psaux"
                    Option          "Protocol"              "auto-dev"
                    Option          "HorizScrollDelta"      "0"
                    Option          "SHMConfig"             "on"
            EndSection
            > ServerLayout Section
            InputDevice "Synaptics TouchPad" "CorePointer"
    - Euro  Enter in ~/.Xmodmap
            keycode 117 = Mode_switch
            keycode 26 = e    E    EuroSign
            Enable by typing <xmodmap ~/.Xmodmap>
    Can't tell an OS by it's GUI

  8. #7
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    You should definitely read the link I posted. There's a whole section devoted to configuring your xorg.conf for touchpads. Freston is correct, you should specify the driver as synaptics. I believe you also need to load the module.

    Code:
    Section "Module"
    	...
    	Load  "glx"
    	Load  "freetype"
    	Load "synaptics"
    	...
    EndSection

  9. #8
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023

    Thumbs down

    Well guys... I got no love out of it.
    Freston, I tried your example configs, and also tried to change them up a bit. Nothing at all different as far as functionality.

    Reed, The link was actually quite educational, but even after trying everything shown, I still didn't get any edge-scrolling.

    I'm just confused here!
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  10. #9
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Bugger. I'm at a loss as well then. Move to Arch?

    What's your xorg.conf look like now? Are there packages available for a more recent xserver? Maybe hotplugging would help you.

  11. #10
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Quote Originally Posted by reed9 View Post
    Bugger. I'm at a loss as well then. Move to Arch?
    Spoken like a true advocate!
    Here's the most pertinent parts of my xorg:
    Code:
    Section "Module"
    
    # This loads the DBE extension module.
    
        Load        "dbe"  	# Double buffer extension
    
    # This loads the miscellaneous extensions module, and disables
    # initialisation of the XFree86-DGA extension within that module.
        SubSection  "extmod"
          Option    "omit xfree86-dga"   # don't initialise the DGA extension
        EndSubSection
    
    # This loads the font modules
        Load        "type1"
        Load        "freetype"
        #Load        "speedo"
    
    # This loads the GLX module
        Load       "glx"
        Load       "synaptics"
    EndSection
    
    # **********************************************************************
    # Files section.  This allows default font and rgb paths to be set
    # **********************************************************************
    
    Section "Files"
    
    # The location of the RGB database.  Note, this is the name of the
    # file minus the extension (like ".txt" or ".db").  There is normally
    # no need to change the default.
    
        RgbPath	"/usr/share/X11/rgb"
    
    # Multiple FontPath entries are allowed (which are concatenated together),
    # as well as specifying multiple comma-separated entries in one FontPath
    # command (or a combination of both methods)
    # 
    # If you don't have a floating point coprocessor and emacs, Mosaic or other
    # programs take long to start up, try moving the Type1 and Speedo directory
    # to the end of this list (or comment them out).
    # 
    
        FontPath   "/usr/share/fonts/local/"
        FontPath   "/usr/share/fonts/misc/"
        FontPath   "/usr/share/fonts/OTF/"
        FontPath   "/usr/share/fonts/TTF/"
        FontPath   "/usr/share/fonts/Type1/"
        FontPath   "/usr/share/fonts/CID/"
        FontPath   "/usr/share/fonts/Speedo/"
        FontPath   "/usr/share/fonts/75dpi/:unscaled"
        FontPath   "/usr/share/fonts/100dpi/:unscaled"
        FontPath   "/usr/share/fonts/75dpi/"
        FontPath   "/usr/share/fonts/100dpi/"
        FontPath   "/usr/share/fonts/cyrillic/"
    
    # ModulePath can be used to set a search path for the X server modules.
    # The default path is shown here.
    
        ModulePath "/usr/lib/xorg/modules"
    
    EndSection
    Here's a part that I added...
    Code:
    Section "InputDevice"
    	Identifier     "Synaptics Touchpad"
    	Driver         "synaptics"
    	Option         "SendCoreEvents"     "true"
    	Option         "Device"             "/dev/psaux"
    	Option         "Protocol"           "auto-dev"
    	Option         "HorizEdgeScroll"   "0"
    	Option         "SHMConfig"          "on"
    EndSection
    And in the Server Layout Section near the bottom:
    Code:
     InputDevice "Synaptics Touchpad" "CorePointer"
    I hadn't looked into updating the Xserver as of yet.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •