Find the answer to your Linux question:
Results 1 to 3 of 3
My distro is KateOS, which is based on Slackware. Started getting problems with depmod. Having rebuilt my own kernel (2.6.29.3), when I run "make modules_install" it bombs out after a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2009
    Location
    South East England
    Posts
    40

    Question 'depmod' problems when trying to install modules


    My distro is KateOS, which is based on Slackware.

    Started getting problems with depmod. Having rebuilt my own kernel (2.6.29.3), when I run "make modules_install" it bombs out after a while with ...

    /bin/sh: line 1: 27167 Killed /sbin/depmod -ae -F System.map 2.6.29.3
    make: ***[_modinst_post] Error 137

    ... this is totally repeatable, other than the 27167 bit, which varies pretty randomly.

    If I just run ...

    /sbin/depmod -ae -F System.map 2.6.29.3

    ... it hangs around for a while and then simply says ...

    Killed

    Sometimes it hangs around for a short while, sometimes it takes a lot longer.

    I have no /etc/modules.conf file. I am running this from my linux 2.6.29.3 sources directory. My kernel build and modules build worked OK, and the modules in /lib/modules/2.6.29.3 seem to be up to date. But no modules.dep file gets created by depmod.

    I've googled this and quite a lot of other people seem to have hit the same problem ... but no-one seems to have found an answer! The fact it takes varying amounts of time before it bombs out (sometimes a few seconds, sometimes minutes) makes me wonder if I'm dealing with a bug of some sort here? Or maybe running out of memory on my elderly PC?

    I have played with the kernel configuration options, turned on some debug etc ... may be a result of this?

    Does anyone have any ideas what's going on here please?

    Thanks

  2. #2
    Just Joined!
    Join Date
    Apr 2009
    Posts
    33
    what is exactly the sequence you follow to build the kernel?
    Perhaps it's because of a discrepancy between the System.map you
    got in /boot and the new one that corresponds to your new built kernel

    I usually do that
    First I make a backup in /boot of vmlinuz*, System.map*, config*
    and of /lib/modules/2.6.2.29.3 it exists
    then
    # cd /usr/src/linux-2.6.29.3
    # make menuconfig
    # make bzImage modules
    # version=${PWD##*-}
    # cp System.map /boot/System.map-$version
    # cp .config /boot/config-$version
    # cp arch/x86/boot/bzImage /boot/vmlinuz-$version
    # cd /boot
    # for f in System.map-$version vmlinuz-$version config-$version
    do
    l=${f%-*}
    ln -sf $f $l
    done

    # cd /usr/src/linux-$version
    # make modules_install

    and, of course, I assume that in your boot loader (lilo or grub)
    the kernel is pointed at as vmlinuz and not
    vmlinuz-someversion
    (that's why I prefer to use a symbolic link, I never have to worry
    forgetting to edit my grub's menu.lst)

  3. #3
    Just Joined!
    Join Date
    Apr 2009
    Location
    South East England
    Posts
    40
    I do much as you do vonbiber, except I do consciously have differently named executables & ramdisc images. One grub option for my normal distro startup and the other for my kernel development startup.

    So far as I understand System.map file in /boot has no effect on the actual startup itself, but will affect the accuracy of error reporting if any get reported. Not sure about config file. But when I have had my dev ones in /boot there seems to be no ill effect on my distro startup for instance.

    However, I decided I'd probably messed around with my config too much to be sure of anything, so to get a peg in the ground I went back to my original distro one as a reference point. Loaded it into menuconfig and saved it straight back out again ... thereby setting all the new config options that came with 2.6.29.3 to their defaults. Rebuilt with this and all is fine. So the moral for me here is never change too much config at a time I think . If I want to configure some debug into my kernel I'll do it softly softly next time.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •