Find the answer to your Linux question:
Results 1 to 3 of 3
This is my first time with a slackware distro. I usually use something like redhat or mandrake because I am lazy and it configures everything for me. Rather than buying ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    4

    I think you have seen this before... my network doesnt work.


    This is my first time with a slackware distro. I usually use something like redhat or mandrake because I am lazy and it configures everything for me.

    Rather than buying mandrake so I can install graphic drivers from nvidia, and instead of figuring out how to install the nvidia drivers on the free version of mandrake, I thought I would save time and switch to a distro that already supports my card without that generic crap (lazy again you see). It was then I discovered how much I liked slackware. But then I tried to connect to the internet...... NO! It dosnt seem to work! It detects my network card, It detects my connectivity, but it won't actually connect. I like slackware so rather than moving to gentoo (which I will do next if I cant figure it out) I would actually like to learn how to fix this sort of problem. Can I get a little information on how to fix this problem?

  2. #2
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    Check out your /etc/rc.d/rc.inet1.conf file.
    Check that on the bottom where is says gateway there is one in between the quotes
    Example
    Gateway"192.168.1.1" #(keep the quotes)

    Sometimes when I go somewhere with my laptop I run netconfig and it wont fill in the gateway for me. It asks but won't write. If it is missing fill it in and reboot. I sometimes have the same issue with DNS /etc/resolv.conf

    I actually have rc.inet1 files called rc.inet1.work, rc.inet1.home so where ever I go I just cp the appropriate file to rc.inet1.conf and reboot and I am off.

    You didn't give enough information with your problem, but I ran into this myself I hope this helps.

    Mike

  3. #3
    Just Joined!
    Join Date
    Oct 2004
    Posts
    4
    Sorry for my lack of information, that worked.

    Just for the future. I guess you also have to go through netconfig before doing that too. thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •