Find the answer to your Linux question:
Results 1 to 6 of 6
I've always mounded my usb drive with /dev/sda1 now i installed Slackware 12.2 and there is not sda1 only sda and it doesn't work. whats going on? is there a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! xzwerm's Avatar
    Join Date
    Jun 2009
    Location
    Canada
    Posts
    10

    mounting usb with sda1


    I've always mounded my usb drive with /dev/sda1 now i installed Slackware 12.2 and there is not sda1 only sda and it doesn't work. whats going on? is there a way to get sda1 back? or do i use something else?

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    I believe since the driver changed a year or two back even IDE drives are referred to as /dev/sd? too, so your own harddrive might be using that identifier. The drive itself doesn't have an sda style name bound to it, they are assigned as you attache more devices. They go in order, e.g. sda, sdb, sdc, sdd etc and the partitions on each device are the number.

    The best thing to do is insert the device and immediately run dmesg for a clue as to what drive it might be. Here's an example where I plugged in an external drive which ended up being identified as /dev/sdh
    Code:
    [  803.936019] usb 2-2: new high speed USB device using ehci_hcd and address 5
    [  804.070268] usb 2-2: configuration #1 chosen from 1 choice
    [  804.071019] scsi9 : SCSI emulation for USB Mass Storage devices
    [  804.071223] usb-storage: device found at 5
    [  804.071226] usb-storage: waiting for device to settle before scanning
    [  809.068495] usb-storage: device scan complete
    [  809.069224] scsi 9:0:0:0: Direct-Access     TOSHIBA  MK6037GSX        0D   PQ: 0 ANSI: 2 CCS
    [  809.070980] sd 9:0:0:0: [sdh] 117210240 512-byte hardware sectors: (60.0 GB/55.8 GiB)
    [  809.071705] sd 9:0:0:0: [sdh] Write Protect is off
    [  809.071708] sd 9:0:0:0: [sdh] Mode Sense: 00 38 00 00
    [  809.071711] sd 9:0:0:0: [sdh] Assuming drive cache: write through
    [  809.072582] sd 9:0:0:0: [sdh] 117210240 512-byte hardware sectors: (60.0 GB/55.8 GiB)
    [  809.079817] sd 9:0:0:0: [sdh] Write Protect is off
    [  809.079821] sd 9:0:0:0: [sdh] Mode Sense: 00 38 00 00
    [  809.079823] sd 9:0:0:0: [sdh] Assuming drive cache: write through
    [  809.079830]  sdh: sdh1
    [  809.108120] sd 9:0:0:0: [sdh] Attached SCSI disk
    [  809.109989] sd 9:0:0:0: Attached scsi generic sg9 type 0

  3. #3
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    Yeah, bigtomrodney is right, that can happen. And I admit it's terribly confusing, specially when you dual boot. I believe, but I'd have to check, that it is a kernel setting though. I have no such confusing stuff on my Slack 12.2 boxen.


    You can also mount devices per hardware address if you want more reliability and/or flexibility.
    First, lets see your
    dmesg|tail
    Run this a few seconds after plugging it the device.
    Can't tell an OS by it's GUI

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer valemon's Avatar
    Join Date
    Oct 2006
    Location
    Volos
    Posts
    934
    Your usb is possibly /dev/sdb. Also fdisk -l would give you a clue.
    Linux is like a Teepee, No Windows, No Gates, Only Apache Inside!
    Arch Linux
    Linux user #442041

  6. #5
    Just Joined!
    Join Date
    Apr 2009
    Posts
    33
    Quote Originally Posted by xzwerm View Post
    I've always mounded my usb drive with /dev/sda1 now i installed Slackware 12.2 and there is not sda1 only sda and it doesn't work. whats going on? is there a way to get sda1 back? or do i use something else?
    if your internal hard drive is SATA then /dev/sda1 is the name of the
    first partition on this hard drive

    Best way to find out the device name of your external usb drive is
    after you inserted the drive (wait for a few seconds then)

    cat /proc/partitions

    look at the last columns
    after eliminating the internal device names (hda* or sda*)
    the next (sda* or sdb* or sdc*) should be the names for the last inserted usb drive

    or you could also as root

    blkid

    this command tells you also the filesystem type

  7. #6
    Just Joined! xzwerm's Avatar
    Join Date
    Jun 2009
    Location
    Canada
    Posts
    10
    thanks i got it, it is sda but it wasn't mounting before because i guess the drive was damaged and had to be formated. somthing must have happend during the installation, but it is sda. thanks again

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •