Find the answer to your Linux question:
Results 1 to 7 of 7
I recently installed slackware and I'm having wireless problems. I'm running slackware 12.2 in the fluxbox environment. I'm trying to connect to a wireless network that has WEP encryption. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    eap
    eap is offline
    Just Joined!
    Join Date
    Jul 2009
    Posts
    4

    Wireless woes


    I recently installed slackware and I'm having wireless problems. I'm running slackware 12.2 in the fluxbox environment. I'm trying to connect to a wireless network that has WEP encryption. I used ndiswrapper to install drivers for my TEW-624 wireless adapter. I'm confident my drivers are installed correctly because when I run iwlist scan, it brings up my wireless network.

    So i try doing this:

    ifconfig wlan0 up
    iwconfig wlan0 essid "default"
    iwconfig wlan0 key "XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XX"
    dhcpcd wlan0

    DHCP times out every time. I checked and modified each setting listed under iwconfig over and over and everything seems fine except the essid. It stays listed as off/any. I'm not sure if this is the culprit or not. I have not gotten it to display default as the essid.

    What are your thoughts?

  2. #2
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    Welcome to the forums!
    Quote Originally Posted by eap
    ifconfig wlan0 up
    iwconfig wlan0 essid "default"
    iwconfig wlan0 key "XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XX"
    dhcpcd wlan0
    I've never tried it, but I don't think 'default' is a valid essid. Just put the name of your access point there.

    And you can also try turning off encryption (temporarily). See if that does work.
    Can't tell an OS by it's GUI

  3. #3
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Quote Originally Posted by eap View Post
    I used ndiswrapper to install drivers for my TEW-624 wireless adapter. I'm confident my drivers are installed correctly because when I run iwlist scan, it brings up my wireless network.
    This does not guarantee that the driver is installed correctly. I can think of at least one instance where a scan shows available networks, but the wireless won't work.

    Please read the stickied thread, linked to below. You can skip to the second part and run the WirelessSetup script, and post the info it retrieves.

    Wireless Setup - Start Here

    This appears to be a 802.11b/g/n USB card. Do you intend to use it as a n wireless? Do you have a wireless n router? If not, you may not need to use NDISwrapper.
    Please do not send Private Messages to me with requests for help. I will not reply.

  4. $spacer_open
    $spacer_close
  5. #4
    eap
    eap is offline
    Just Joined!
    Join Date
    Jul 2009
    Posts
    4
    This is an 802.11 g network. The device works through usb, and works up to 802.11 n. I will need to to have it configured for an n router at some point, so it is important I get this working. I'll let report back after I've ran your script.

    Quote Originally Posted by Freston View Post
    Welcome to the forums!

    I've never tried it, but I don't think 'default' is a valid essid. Just put the name of your access point there.

    And you can also try turning off encryption (temporarily). See if that does work.
    Sorry for confusion. The access point is actually named default.

  6. #5
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    I've had a problem similar to this and the way that I solved it was to manually assign an IP to the device. But this may not work for you.
    Code:
    ifconfig wlan0 192.168.1.70
    Of course you need to enter a valid IP address for this to work.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  7. #6
    Just Joined!
    Join Date
    Apr 2009
    Posts
    33
    Quote Originally Posted by eap View Post
    I recently installed slackware and I'm having wireless problems. I'm running slackware 12.2 in the fluxbox environment. I'm trying to connect to a wireless network that has WEP encryption. I used ndiswrapper to install drivers for my TEW-624 wireless adapter. I'm confident my drivers are installed correctly because when I run iwlist scan, it brings up my wireless network.

    So i try doing this:

    ifconfig wlan0 up
    iwconfig wlan0 essid "default"
    iwconfig wlan0 key "XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XX"
    dhcpcd wlan0

    DHCP times out every time. I checked and modified each setting listed under iwconfig over and over and everything seems fine except the essid. It stays listed as off/any. I'm not sure if this is the culprit or not. I have not gotten it to display default as the essid.

    What are your thoughts?
    I have slackware 12.2 and and a wireless card with the same interface name (wlan0)
    this is what I did:
    I edited /etc/rc.d/rc.inet1.conf
    Right after
    IPADDR[0]...
    ....
    DHCP_HOSTNAME[0]....

    I put this:

    IFNAME[1]="wlan0"
    #IPADDR[1]=""
    #NETMASK[1]=""
    USE_DHCP[1]="yes"
    #DHCP_HOSTNAME[1]=""
    #WLAN_MODE[1]=Managed

    ################
    I don't have a fixed IP address, that's why I had the
    entry
    USE_DHCP[1]="yes"
    I don't go to encrypted wifi hotspots so I don't have en entry
    for WEP, you'll have to read the doc to add the appropriate entry
    in /etc/rc.d/rc.inet1.conf

    Once this file has been correctly edited, every time you boot
    you should be connected and assigned an IP address

    if this command

    iwgetid wlan0

    doesn't display your essid

    or/and if

    ifconfig wlan0

    doesn't display an IP address (or wlan0 is not up)
    you can try to launch it manually by (all of this above and below is as root)

    /etc/rc.d/rc.inet1 stop

    iwconfig wlan0 essid "replace_here_by_your_essid"

    /etc/rc.d/rc.inet1

    ifconfig wlan0

    you should see an IP address

  8. #7
    eap
    eap is offline
    Just Joined!
    Join Date
    Jul 2009
    Posts
    4
    Quote Originally Posted by vonbiber View Post
    I have slackware 12.2 and and a wireless card with the same interface name (wlan0)
    this is what I did:
    I edited /etc/rc.d/rc.inet1.conf
    Right after
    IPADDR[0]...
    ....
    DHCP_HOSTNAME[0]....

    I put this:

    IFNAME[1]="wlan0"
    #IPADDR[1]=""
    #NETMASK[1]=""
    USE_DHCP[1]="yes"
    #DHCP_HOSTNAME[1]=""
    #WLAN_MODE[1]=Managed

    ################
    I don't have a fixed IP address, that's why I had the
    entry
    USE_DHCP[1]="yes"
    I don't go to encrypted wifi hotspots so I don't have en entry
    for WEP, you'll have to read the doc to add the appropriate entry
    in /etc/rc.d/rc.inet1.conf

    Once this file has been correctly edited, every time you boot
    you should be connected and assigned an IP address

    if this command

    iwgetid wlan0

    doesn't display your essid

    or/and if

    ifconfig wlan0

    doesn't display an IP address (or wlan0 is not up)
    you can try to launch it manually by (all of this above and below is as root)

    /etc/rc.d/rc.inet1 stop

    iwconfig wlan0 essid "replace_here_by_your_essid"

    /etc/rc.d/rc.inet1

    ifconfig wlan0

    you should see an IP address
    Yeah I was playing with the rc.inet1.conf file yesterday. I still couldn't get it to connect. Then I changed the mode in iwconfig from restricted to open. It finally got the essid to display my access point instead of off/any, and the connection now shows 43/100 instead of 0. But I still do not have an internet connection. Running the network without encryption is not an option for me. I'm able to detect my access point, and I have entered the WEP key, shouldn't I be able to connect?

    ---
    edit
    ---

    Finally I'm posting from my Slackware computer. When I restart my computer though, I have to type
    Code:
    iwconfig wlan0 key open
    because it doesn't want to seem to save this setting so my computer can see the network. I also have to call
    Code:
    dhcpcd wlan0
    to connect each time because I'm not sure why it won't connect using the rc.inet1.conf file. But I'll keep at it. Thanks for replies everyone, it really helped me out. I'll post back if I have any further questions. Thanks again!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •