Find the answer to your Linux question:
Results 1 to 9 of 9
i just installed slax w/ the lxde module and everytime i reboot (usb drive) it loads fluxbox; and start-lxde didnt' work when i rebooted slax in text mode...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2009
    Posts
    17

    slax with lxde how to start lxde?


    i just installed slax w/ the lxde module and everytime i reboot (usb drive) it loads fluxbox; and start-lxde didnt' work when i rebooted slax in text mode

  2. #2
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,116
    Live USB doesn't save changes.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  3. #3
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,116
    Disregard my last post it seems that
    Updated 3/18/08: It appears that in newer versions of Slax (6.0.3+) includes install scripts and persistence is now automatic.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  4. #4
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,116
    try
    startx lxde
    when i rebooted slax in text mode
    but logged in as root user.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  5. #5
    Just Joined!
    Join Date
    Apr 2009
    Posts
    17
    startx lxde acted like it was going to work, then kicked me to command line

    listed all the x options

  6. #6
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,116
    Some dependency is missing from your lxde install it from what I can tell. You should have gotten some error message that tells you during the startup on why lxde wouldn't start.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  7. #7
    Just Joined!
    Join Date
    Apr 2009
    Posts
    17
    no error message, i did a build ur own slax and most def triple checked to make sure i downloaded dependency's. when i choose any option other than start slax in textmode, it auto loads FLUXBOX, and i want to use LXDE since it has all my programs configured. i checked into configure files and the lxde desktop file does exist, with all the modules shown on it. not sure how to get it to start.

  8. #8
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,116
    Since I don't run slax I am out of ideas on how to get you sorted. If everything is there. Do you have a menu option in fluxbox to enable slim or kdm login window so you can log in with user name and password. The reason I ask is on your gui login window there should be a sessions tab. You should be able to pick out lxde from the sessions tab if it is installed correctly. I enable all the login windows on my installs and I run LXDE/gnome in Ubuntu and MoonOS. I can pick LXDE from sessions in my login window gui. In AntiX I have the choice of running Icewm and Fluxbox using slim. That is why I mentioned Slim. In Ubuntu running Gnome it is called GDM. So If running Fluxbox in Slax I think Slim would be your login GUI Window. Just guessing here because I don't run Slax.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  9. #9
    Just Joined!
    Join Date
    Apr 2009
    Posts
    17
    another day another problem...

    after numerous search's, i found a useful reference to xwmconfig command.

    alright so i type this into my textbox.... found a option to select desktop manager! it lights up fluxbox, LXDE, and openbox. naturally i select LXDE.....

    ok back to the command prompt. xconf followed by startx.
    alright now im looking at a frozen keyboard and black screen light up by a single X in the middle......

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •