Find the answer to your Linux question:
Results 1 to 3 of 3
Trying to install slackware 10 to hp ml110 server with Promise Fasttrak S150 TX4 sata raid controller and 4x80Gb hard disks. Boot image sata.i from current-tree has no glue on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    3

    Promise Fasttrak S150 TX4 sata raid-5


    Trying to install slackware 10 to hp ml110 server with Promise Fasttrak S150 TX4 sata raid controller and 4x80Gb hard disks.

    Boot image sata.i from current-tree has no glue on my raid-5 array, instead it is showing me /dev/sda ..b..c..d.

    Maybe someone has tried the same/kind of hardware raid-5 with slackware. Have you succeeded with it?

  2. #2
    Just Joined!
    Join Date
    Oct 2004
    Posts
    3
    Hi again!

    I managed to install slackware. First, my raid-controller is S150 SX4, not TX4.

    How I did this; found after 5hour googleing, post from other miserable SX4 user. He was asked from promise support and they had give the source code for linux kernel module. After downloading that, I did what the readme told. Compiled the module source against slackware installer kernel source and that did the trick. With module, the raid-5 array was found under /dev/sda and installation of slackware was possible. Now I have to find out how to boot to that array, because the kernel needs that module to mount /.

    link to source code:

    http://trotch.com/redhat/promise/Fas...new_README.zip

    And the post:

    http://trotch.com/redhat/promise/email.html

  3. #3
    Just Joined!
    Join Date
    Oct 2004
    Posts
    3
    .....and now it works. Managed to boot to /dev/sda with compiled module and made with mkinitrd ramdisk for boot-up. Added the module there and voilé.
    After all I have to say that promise support for linux _could_ be better...

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •