Find the answer to your Linux question:
Results 1 to 4 of 4
This might have been answered before.. but I did not find it. I'm using Slackware 10 with agetty. How would I go about removing my hostname from the login: prompt? ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    17

    Slack 10 w/ agetty


    This might have been answered before.. but I did not find it. I'm using Slackware 10 with agetty. How would I go about removing my hostname from the login: prompt?

    like:
    login:

    not:
    hostname login:

    YES.. I noticed /etc/gettydefs .. but agetty does not use that file getty does.
    Yup I even tried editing /etc/inittab and it made the kernel panic when I had some bad settings in there.. could not start agetty on ANY consoles.. that was bad.. luckily I booted into runlevel 1 and fixed it.

    Yes.. I have googled for hours looking for the answer.

    Trying to make my system a little more secure.

    Any help is appreciated.

  2. #2
    Just Joined!
    Join Date
    Oct 2004
    Posts
    13

    your login type

    I had a similar problem when I started my install. I actually waited to install my network until later. As I remember I reconfigured my install prompt to not include the network setup. When i did this, I get the root login. Make sure to note any passwords you might make. otherwise you might lock yourself out of loging in..... I'm working on my system currently learning the capabilities of it and appreciate it's simplicity noting technical experience.. Good luck.

  3. #3
    Just Joined!
    Join Date
    Aug 2004
    Posts
    17
    Ok.. I guess no one really has the desire to do this with their system.. so oh well.

    I was playing around and decided to run getty (not agetty) on console 8. And, well, it sucks. Now I know why Pat Volkerding (guy who made Slackware) uses agetty as default. Getty is simply buggy. Although, it did allow me to remove my hostname from the login: prompt. Further reading....reading....reading... I found that agetty does not use config files of any kind. It displays the hostname by default and there is no option to turn it off.. I will just have to deal with it.

  4. #4
    Just Joined!
    Join Date
    Oct 2004
    Posts
    13

    agetty

    what desktop do you normally want to use? KDE. Gnome?

    FYI, if you open a terminal box. then type in pkgtool, you can change your sign in procedure as well. just reconfigure with pkgtool of what type of start up you want. also, if in the procedure list, you choose not to setup your network, you will bypass your:

    hostname login: <prompt>

    you should then have a:

    login: <prompt>

    That pkgtool prog will allow you to change anytime through your term prog. Let me know what you think about this yourself. when you try it.
    Your pkgtool will run fine through the dos window....

    Hope this helps, I'm not sure how far along your are in your setup. I havent tried agetty, but it seems like I will not be trying it soon....thanks for the info on the bug out.... agetty.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •