Find the answer to your Linux question:
Results 1 to 3 of 3
I have just installed slack 10.0 on my machine and I cannot get the sound to work. I'm running it on a notebook computer with a P4 2.4 gig processor, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Location
    Osaka, Japan
    Posts
    4

    Error while initializing the sound driver


    I have just installed slack 10.0 on my machine and I cannot get the sound to work. I'm running it on a notebook computer with a P4 2.4 gig processor, and the sound is built on to the motherboard. When I ran Windows it recognized my sound drivers as a AC'97 Sound Card.

    My problem now is that when I log on to KDE it tells me:

    Informational - artsmessage:

    Sound server informational message:
    Error while initializing the sound driver:
    device /dev/dsp can't be opened (No such device)
    The sound server will continue, using the null output device.

    When I look at the dsp entry from the terminal, it states this:
    root@napps:/dev# ls -l dsp
    lrwxrwxrwx 1 root root 4 2004-10-12 03:28 dsp -> dsp0
    root@napps:/dev#

    and when I do the same for dsp0:

    root@napps:/dev# ls -l dsp0
    crw-rw--w- 1 root audio 14, 3 2003-08-29 16:47 dsp0
    root@napps:/dev#

    anyway, as you can see I am already logged in as root, so its not merely a problem of accessing the sound files. I don't know how to proceed and any help would be appreciated,

    thanks,

  2. #2
    Linux Newbie
    Join Date
    Oct 2004
    Location
    Manchester, England
    Posts
    165
    try making yourself a member of the audio group or chmod 777 /dev/dsp*

  3. #3
    Linux Newbie
    Join Date
    Jan 2004
    Location
    UK
    Posts
    131
    how did you install slack10? did you create a swap partition? and a root partition?

    I had the same problem when i first installed slack10 on a dual boot laptop, to then realize that to fix this problem I had to create a slack swap partition - that's how I fixed it - I did try chmod 775 /dev/dsp but it didnt work - I hope that this will help you

    p.s.: after, and if it works, you should open volume control to set all the volume sliders in your mixer - good luck
    If you get on the wrong train all the stations you will come to will be the wrong stations.
    Zen

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •