Find the answer to your Linux question:
Results 1 to 3 of 3
I have an issue with my 802.11* wireless lan on an x86 laptop. The issue is as follows: I am associated with the AP (as per iwconfig and per dmesg), ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Jul 2007
    Posts
    111

    Wireless lan no working.


    I have an issue with my 802.11* wireless lan on an x86 laptop.

    The issue is as follows:

    I am associated with the AP (as per iwconfig and per dmesg), then I attempt to get an IP through DHCP, which fails:

    Code:
    x86_20# dhclient
    Internet Systems Consortium DHCP Client V3.0.6
    Copyright 2004-2007 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/
    
    wmaster0: unknown hardware address type 801
    wmaster0: unknown hardware address type 801
    Listening on LPF/wlan0/00:13:e8:f6:c4:55
    Sending on   LPF/wlan0/00:13:e8:f6:c4:55
    Listening on LPF/wmaster0/
    Sending on   LPF/wmaster0/
    Listening on LPF/eth0/00:1e:8c:22:ca:27
    Sending on   LPF/eth0/00:1e:8c:22:ca:27
    Sending on   Socket/fallback
    DHCPDISCOVER on wmaster0 to 255.255.255.255 port 67 interval 7
    DHCPREQUEST on wlan0 to 255.255.255.255 port 67
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
    DHCPNAK from 10.8.12.1
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
    DHCPDISCOVER on wmaster0 to 255.255.255.255 port 67 interval 7
    receive_packet failed on wlan0: Network is down
    receive_packet failed on wmaster0: Network is down
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 12
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10
    DHCPDISCOVER on wmaster0 to 255.255.255.255 port 67 interval 10
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 15
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 15
    DHCPDISCOVER on wmaster0 to 255.255.255.255 port 67 interval 21
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 9
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 20
    ...
    This continues until DHCPI timeout, there is nothing wrong with the DHCP server, nor the WLAN itself.

    Sometimes it works, whereas other times I see per dmesg and per iwconfig that the radio has been disconnected from the AP just as I get the

    "receive_packet failed on wlan0: Network is down
    receive_packet failed on wmaster0: Network is down"

    If I constantly force the device to associate by binding it to the hardware address of the AP, frequency and ESSID, then it sometimes manages to get an IP -- once it first has an IP, it never seems to fail.

    But here is the interesting thing, sometimes the following happens (even if I don't try to 'help' it staying associated like just described):

    Code:
    x86_20# dhclient
    Internet Systems Consortium DHCP Client V3.0.6
    Copyright 2004-2007 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/
    
    wmaster0: unknown hardware address type 801
    wmaster0: unknown hardware address type 801
    Listening on LPF/wmaster0/
    Sending on   LPF/wmaster0/
    Listening on LPF/eth0/00:1e:8c:22:ca:27
    Sending on   LPF/eth0/00:1e:8c:22:ca:27
    Listening on LPF/wlan0/00:13:e8:f6:c4:55
    Sending on   LPF/wlan0/00:13:e8:f6:c4:55
    Sending on   Socket/fallback
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
    DHCPDISCOVER on wmaster0 to 255.255.255.255 port 67 interval 5
    DHCPREQUEST on wlan0 to 255.255.255.255 port 67
    DHCPNAK from 10.8.12.1
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
    receive_packet failed on wmaster0: Network is down
    receive_packet failed on wlan0: Network is down
    DHCPOFFER from 10.8.12.1
    DHCPREQUEST on wlan0 to 255.255.255.255 port 67
    DHCPACK from 10.8.12.1
    bound to 10.8.12.55 -- renewal in 123284 seconds.
    Also of interest might be (by dmesg)

    Code:
    [   61.741544] iwlagn: TX Power requested while scanning!
    This sometimes appear in my kernel ring buffer.

    I have tried different APs, with the same result -- no other computer than my own suffers from this issue.
    I have tried with Windows Vista (oh my god), where it always works perfectly fine.
    I have tried several different kernels, including my own custom compiled ones -- thus having tried different versions of the wlan driver as well.
    I have tried different microcode firmware for the iwl4965 802.11* device.
    I have executed a memtest86 test to confirm that the RAM is not damaged.
    I have executed numerous CPU stress tests to ensure that the CPU is not damaged nor executes and faults.
    I have tried different versions of the NVIDIA drivers for the 8600M graphics card.
    I have tried to use the vesa driver instead of NVIDIA proprietary drivers.

    Computer: Asus G1S
    OS: GNU/Linux Slackware 12.2.0 (currently)
    Kernel: Custom/optimized 2.6.27.8 (currently)
    WLAN device: 03:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)
    ucode: iwlwifi-4965-2.ucode

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Try disable the hardware scan.

    To do so, create a file in /etc/modprobe.d/ - you can pretty much call it whatever you want, and it's good practice to end the filename with the .conf. (This will be required in a future release.) So wireless.conf or whatnot.

    Add the line option iwl4965 disable_hw_scan=1

    Save and reload the module.
    Code:
    su -
    modprobe -r iwl4965
    modprobe iwl4965

  3. #3
    Linux Newbie
    Join Date
    Jul 2007
    Posts
    111
    Quote Originally Posted by reed9 View Post
    Try disable the hardware scan.

    To do so, create a file in /etc/modprobe.d/ - you can pretty much call it whatever you want, and it's good practice to end the filename with the .conf. (This will be required in a future release.) So wireless.conf or whatnot.

    Add the line option iwl4965 disable_hw_scan=1

    Save and reload the module.
    Code:
    su -
    modprobe -r iwl4965
    modprobe iwl4965
    Thanks, I'll try that next time I'm at the university.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •