Find the answer to your Linux question:
Results 1 to 3 of 3
So I'm trying to upgrade to the latest Slackware, from 12.2 to 13 doing a clean install. I've managed to get KDE4 and all my apps happily running the way ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2009
    Posts
    5

    Unhappy Slackware 13: OpenOffice refuses to use GTK2/KDE4 themes.


    So I'm trying to upgrade to the latest Slackware, from 12.2 to 13 doing a clean install. I've managed to get KDE4 and all my apps happily running the way I want them except for this one problem. OpenOffice.org simply refuses to use either GTK themes or KDE ones. It merely sits there being ugly. Now on Slackware 12.2 I installed the gtk-qt-engine-1.1 and that worked for all of my GTK programs, but on my new system this had no effect. So rather then I went and downloaded gtk-kde4 and this worked like a charm for GTK apps. My current style is QtCurve and I've installed both the GTK2 and KDE4 versions, so unless a program is incapable of rendering with either, I should get QtCurve no matter what.

    OpenOffice.org remains to be an exception. I first installed it from the latest build from SlackBuilds, but was met with a terrible grey scheme circa Windows 95 style. I thought perhaps it would be best to install the latest version from the OOo site itself. I downloaded all the rpms and made them into Slackware tgz packages but to no avail. What astounds me is that there were distinct packages, namely ooobasis3.1-gnome-integration-3.1.1-9420.i586.tgz and ooobasis3.1-kde-integration-3.1.1-9420.i586.tgz that imply that OOo should be able to play nice with either style. Both are installed along with the rest of the office suite, but they don't seem to be doing any favors for me at this point.

    So what's the deal? Has anyone gotten OOo to install and look alright using GTK or KDE themes for the new Slackware 13? I've been at this for hours already, and it's the one last true hurdle keeping me from adopting Slackware 13 and KDE4 (I've been sticking with KDE 3.5, holding out for this release).

  2. #2
    Just Joined!
    Join Date
    Dec 2007
    Posts
    1
    why don't you use xfced instead
    I had tried kde4 in slackware 13
    I had no choice but change to xfced
    It is simple and beautiful like kde 3.5 while I still using slackware 13
    I just type startxfce4 instead of startx
    and everything is solved
    I never use xfce before but I must say that it is nicer than my beloved kde

  3. #3
    Just Joined!
    Join Date
    Aug 2009
    Posts
    5
    Well, actually, I've solved this problem already, a while ago really. I had to make a script (for launching the program from the KDE classic menu) that forced OOo to use GTK2. Since my KDE & GTK themes are the same (QtCurve) it didn't really matter.

    As for xfce, I have low opinions of that window manager. I left it out of my Slackware 13 install expressively because I adamantly disapprove of it. I wouldn't touch it for the life of me, but that's getting off track. At least my problem is solved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •