Find the answer to your Linux question:
Results 1 to 3 of 3
Hi guys, I'm trying to run texmaker on slackware 13. I runs fine under KDE, however when I switch to either fluxbox or xfce, I get the following error: Code: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Feb 2009
    Posts
    104

    QGtkStyle cannot be used together with the GTK_Qt engine


    Hi guys,
    I'm trying to run texmaker on slackware 13. I runs fine under KDE, however when I switch to either fluxbox or xfce, I get the following error:

    Code:
    QGtkStyle cannot be used together with the GTK_Qt engine.
    Segmentation fault
    I've run qtconfig and tried all themes (gtk, cleanlooks, oxygen, etc) but I still get this error.

    How could I solve it? Once I've configured fluxbox (and tried xfce) I don't really want to go back to KDE.

    Thanks

  2. #2
    cad
    cad is offline
    Just Joined!
    Join Date
    Nov 2009
    Location
    Ithaca, NY
    Posts
    1

    same problem

    I see this is an older post, but I'm having the same problem.

  3. #3
    Just Joined!
    Join Date
    Dec 2009
    Location
    Belgrade, Serbia (SE Europe)
    Posts
    1

    Thumbs up solution

    I had the same problem. The solution was to upgrade Qt from Slackware 13.0 default Qt 4.5.1 to latest (as of Dec 19 2009) Qt 4.5.3. The problem with Qt 4.5.1 was install script, maybe because it was written to fit with KDE(I) software series and after removing KDE it became unstable... Texmaker works fine on the Slackware 13.0 with Qt 4.5.3. There is no needs for gtk-qt-engine, etc.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •