Hi all,
Let me start by saying that i never had problems when installing or updating GIMP /when i was with slackware 12.2/
i decided to upgrade from 2.6.6 to gimp 2.6.7. There isnt a precompiled package for Slackware 13 so i downloaded from source. Configured and compiled with no errors. but when i start gimp i get:

Code:
Libgimp version mismatch!

The GIMP binary cannot run with a libgimp version
other than its own. This is GIMP 2.6.6, but the
libgimp version is 2.6.7.

Maybe you have GIMP versions in both /usr and /usr/local ?
There is no gimp folder in either of /usr and /usr/local

So i removed the 2.6.7 packages, and i still get the same err. I reinstalled the 2.6.6 package precompiled for Slackware 13, but still the same. So now i dont have working GIMP. I believe i did some rookie mistake

Any suggestions are welcome

Distro: Slackware 13
Kernel-2.6.29.6
KDE 4.2.4