Find the answer to your Linux question:
Results 1 to 5 of 5
Hi guys, I am using Slackware 13.0 (x86). One of the programs I reaaly need to use is Qtstalker. When I try to compile this program, I get qt-related error. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    4

    Qtstalker Installation


    Hi guys,
    I am using Slackware 13.0 (x86). One of the programs I reaaly need to use is Qtstalker. When I try to compile this program, I get qt-related error. In the past I've used Ubuntu, which had two QT packages: qt & qt-dev. Do I need to install qt-dev package on my slackware box ?

    Thanks,

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Can you post the exact error message? It would be really helpful.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Just Joined!
    Join Date
    Dec 2006
    Posts
    4

    qtstalker compilation

    Hi Mike,

    Thank you for your prompt reply. Sorry, I wasn't that quick--I've been sick lately. Here the error I am getting:

    g++ -c -pipe -ffast-math -Wall -W -g -D_REENTRANT -fPIC -DQT_NO_COMPAT -DQT_THREAD_SUPPORT -DQT_SHARED -DQT_NO_DEBUG
    -I/usr/lib/qt/mkspecs/default -I. -I/usr/local/include/ta-lib -I/usr/lib/qt/include -o UpgradeMessage.o UpgradeMessage.cpp
    UpgradeMessage.cpp: In member function 'void UpgradeMessage::copyFiles()':
    UpgradeMessage.cpp:447: error: 'system' was not declared in this scope
    UpgradeMessage.cpp:454: error: 'system' was not declared in this scope
    UpgradeMessage.cpp:466: error: 'system' was not declared in this scope
    UpgradeMessage.cpp:472: error: 'system' was not declared in this scope
    UpgradeMessage.cpp:484: error: 'system' was not declared in this scope
    UpgradeMessage.cpp:496: error: 'system' was not declared in this scope
    make[1]: *** [UpgradeMessage.o] Error 1
    make[1]: Leaving directory `/root/Desktop/qtstalker-0.36/lib'
    make: *** [sub-lib] Error 2

    There are three dependencies for 'qtstalker': QT (=> 3.3), Berkeley DB (=>4.1), and TA-LIB (=> 0.3.0). I have compiled and installed them properly. I also tried to use QT that came with Slackware 13.0 DVD and the one I downloaded from 'trolltech dot com/'. Neither one let's me compile 'qtstalker'.

    Any help or pointer would be appreciated. Thanks, Paul.


  4. #4
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Hello and Welcome back from being sick, that is never pleasant and we're glad you feel better. I'm not having much luck tracking down an exact answer for you but have you looked in your system repos to see if it's already available? It's available on Gentoo systems and this should make installing it much easier than compiling from source. About all I can think of is to make absolutely sure that you have met all the depends and systems requirements, read all the included README and INSTALL files you can find in the package that you downloaded.
    Code:
    emerge -s qtstalker
    Searching...    
    [ Results for search key : qtstalker ]
    [ Applications found : 1 ]
    
    *  app-office/qtstalker
          Latest version available: 0.36
          Latest version installed: [ Not Installed ]
          Size of files: 1,369 kB
          Homepage:      Qtstalker - Commodity and stock market charting and technical analysis
          Description:   Commodity and stock market charting and technical analysis
          License:       GPL-2
    EDIT: a little more investigating reveals that I need ta-lib-0.4.0 to install this program, check to see if you have it.
    Last edited by MikeTbob; 12-07-2009 at 01:02 AM. Reason: See EDIT:
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  5. #5
    Just Joined!
    Join Date
    Dec 2006
    Posts
    4

    qtstalker compilation

    Thank you Mike,

    I will double-check 'ta-lib' version and will try to compile it again. If it's not going to work, I will give Gentoo a try.

    Many thanks again,

    Paul

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •