Find the answer to your Linux question:
Results 1 to 4 of 4
Just installed Slackware 13.0. Using 56k usrobtics modem. I can hear the handshake and the lights and my scripted indicators suggest I am making the connection to my ISP. But ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    Mar 2008
    Posts
    287

    Internet access problem


    Just installed Slackware 13.0.
    Using 56k usrobtics modem. I can hear the handshake and the lights and my scripted indicators suggest I am making the connection to my ISP.
    But when I run Firefox it can't find Google (home page ). I got smart and tried to use the Firefox help button but that also gave me a cant find page error also.
    I tried accessing the ISP without the firewall also and got the same message.
    Any suggestions?

  2. #2
    Linux User saivin's Avatar
    Join Date
    Dec 2008
    Location
    Bengaluru, India
    Posts
    305
    If you have installed Slackware with 'default' mode, almost all the drivers would have been installed. So, mostly no issues with drivers. Open a terminal, become root and try the following:
    Code:
    su -
    /sbin/ifconfig eth0
    if it does not show up,
    Code:
    /sbin/ifconfig eth0 up
    then we need to get ip address with
    Code:
    /sbin/dhcpcd eth0
    if we get ip then try
    Code:
    ping -c 3 www.google.com
    You may also have to see if rc.inet1 script is executable in /etc/rc.d
    Code:
    chmod a+x /etc/rc.d/rc.inet1
    P.S: Make sure Firefox is not in Offline mode (under File option).
    A candle looses nothing by lighting other candles. - Khalil Zibran.
    Registered Linux User #490076

  3. #3
    Linux User
    Join Date
    Mar 2008
    Posts
    287
    This is a single user workstation hence not using eth0 or dhcp just ppp.
    My /var/log/messages shows that I am connected but when I ping an always up site I get: page not found. Verified without firewall.
    Since the same hardware is used to write this (dual booted) it should not be the hardware.
    Aren't most rc.d scripts supposed to be set 640 to prevent unauthorized users?
    Last edited by clickit; 11-25-2009 at 03:25 AM.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    Mar 2008
    Posts
    287

    Internet access problem

    Here is more info:
    resolv.conf, host.conf, and nsswitch.conf (and -nis) all were validated against what I have found on the internet to be correct, especially notes nsswitch.conf does contain "hosts: files dns".
    Pinging an IP address returns: network unreachable
    Pinging a FQDN returns: unknown host
    Traceroute returns: "findaddr: Can't find interface"
    /var/log/messages shows that ppp0 is connected to ttyS0 but DOES NOT show the local and remote IP addresses.
    Oh, yes my ISP bill is paid up so they shouldn't have turned me off.
    I am using the same scripts that I used with 12.0 and they are working. I am just not getting my server to go that last step or I am not accepting what he is doing.
    I am really out of options and need some tolerant help as I am forced to use XP to communicate from the same machine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •