Find the answer to your Linux question:
Results 1 to 2 of 2
Installing Canon IP1800 under Slack 13.0 from same tar files as were used on 12.0 (cnijfilter-common_2.70-1_i386.tar and cnijfilter-ip1800series_2.70-1...). lpadmin -p IP1800 -m canonip1800.ppd -v cnij_usb:/dev/usb/lp0 -E yields: Bad device-uri "cnij_usb:/dev/usb/lp0" ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    Mar 2008
    Posts
    287

    Bad device-uri for Canon ip1800


    Installing Canon IP1800 under Slack 13.0 from same tar files as were used on 12.0 (cnijfilter-common_2.70-1_i386.tar and cnijfilter-ip1800series_2.70-1...).
    lpadmin -p IP1800 -m canonip1800.ppd -v cnij_usb:/dev/usb/lp0 -E yields:
    Bad device-uri "cnij_usb:/dev/usb/lp0"
    Didn't happen on 12.0 as I recall and double check my install list up to this point and all was OK.
    WARNING -- DO NOT BUY THIS PRINTER it is a pain to install and drivers available only in southeast asia from Canon.

  2. #2
    Linux User
    Join Date
    Mar 2008
    Posts
    287

    [SOLVED] Bad DeviceURI for Canon ip1800

    This is an UPDATE to my original query.
    I found at one site (notes got lost somewhere) that
    1) if /usr/sbin/lpadmin -p ip1800 -m canonip1800.ppd -v cnij_usb:/dev/usb/lp0 -E,
    gives the above error, then
    2) Edit /etc/cups/printers.conf by changing the DeviceURI to:
    DeviceURI file:/dev/usb/lp0, then
    3) restart CUPS
    4) issue: /usr/sbin/lpadmin -p ip1800 -m canonip1800.ppd -v /dev/usb/lp0
    This also does not work! I went back and tried changing printers.conf to cnij_usb:/dev/usb/lp0 which also does not work.
    When the lpadmin uses -v /dev/usb/lp0 the message is:
    lpadmin: File device URIs have been disabled? To enable see the FileDevice directive in /etc/cups/cupsd/cupsd.conf. First off cupsd.conf resides in /etc/cups.
    Secondly, there is no FileDevice directive to mimic. This looks like the most logical means of correction if someone knows how to setup the FileDevice directive.

    Lastly, the aforementioned URL says if neither 1) nor 4) works to bring up
    http://localhost:631/printers which is kind of scarey as so far I have not been able to get that to work with Slack 13.0 and Firefox 5.

    Have seen that some distros use blacklisting of usblp but do not fully understand why. Can someone clear this up for me also?
    Any help will be appreciated as this is getting to be a twisted tail.
    ===========================
    SOLUTION:
    /etc/cups/cupsd.conf
    Contains following line at bottom of file: DefaultLanguage en_GH

    /etc/cups/printers.conf
    DeviceURI line is originally DeviceURI file:/dev/null was changed to:
    DeviceURI file:/dev/usb/lp0

    Printer ON and restart CUPS
    Use: http://localhost:631/printers to setup printer to be published, set as default,
    and started.
    WOW! It did work under test page and a document from my directory.
    Last edited by clickit; 11-30-2009 at 11:19 AM. Reason: Solution

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •