Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
hello every one I can't figure out how to change the root and user permission for all my partitions in my /dev/hda - when I'm logged in as a user, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Jan 2004
    Location
    UK
    Posts
    131

    root's and user's permission


    hello every one

    I can't figure out how to change the root and user permission for all my partitions in my /dev/hda - when I'm logged in as a user, slack10 won't let me access my own partitions, i.e: 'windows' (dual boot), nor even '/home' - i tried to change permission in '/etc/fstab' and also tried 'su' but nothing seems to work -

    is there a file that governs all software and hardware permission? if so, what is that?

    can anyone help pls?
    If you get on the wrong train all the stations you will come to will be the wrong stations.
    Zen

  2. #2
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    what happns when you try to su? Do you boot to gui or to shell?
    can you log in as root at login time?

  3. #3
    Linux Newbie
    Join Date
    Mar 2003
    Location
    Istanbul/Türkiye
    Posts
    246
    This is a Slack special state. First got the root rights wtih
    Code:
    su -
    not with just su command. Then edit your /etc/fstab file. Edit the desired partition like
    /dev/hda1 /mnt/w2k -t ntfs -r -o umask=0222
    that. dont forget to add umask=0222. This is just an example edit your file like your needs. i.e if you have fat, you can change -r part.
    Just a Newbie....Looking 4 Info....

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie imdeemvp's Avatar
    Join Date
    Sep 2004
    Location
    California
    Posts
    225
    what about if it was a fat32 partition?

  6. #5
    Linux Newbie
    Join Date
    Mar 2003
    Location
    Istanbul/Türkiye
    Posts
    246
    it is similar

    /dev/hda1 /mnt/w2k -t vfat -rw -o umask=0222
    Just a Newbie....Looking 4 Info....

  7. #6
    Linux Newbie imdeemvp's Avatar
    Join Date
    Sep 2004
    Location
    California
    Posts
    225
    Quote Originally Posted by heartsmagic
    it is similar

    /dev/hda1 /mnt/w2k -t vfat -rw -o umask=0222
    its not auto mounting for me any ideas why?

  8. #7
    Linux Newbie
    Join Date
    Mar 2003
    Location
    Istanbul/Türkiye
    Posts
    246
    If i understand right you want to mount it automatically.
    Then you shuould add the "auto" part,



    Code:
    /dev/hda1 /mnt/w2k -t vfat -rw -o users,auto,umask=0222
    Dont forget, this is just a sample. Change the partitions and directory names for your needs.
    Just a Newbie....Looking 4 Info....

  9. #8
    Linux Newbie
    Join Date
    Jan 2004
    Location
    UK
    Posts
    131
    sorry been very busy with fixing everything else on my box and now that everything seems to work fine I think I understood - the 'su' line works fine and in fact I get root privilege on console even if i'm logged in as 'user' - but still it won't let me open my partition on 'X' (graphical interface) and I came to the conclusion that perhaps it's a security feature of slack10

    talking about 'su' and 'root' privilege, yesterday after just 1 week of everything working fine, my 'gyach' interface decided no to work anymore when i try to log in to it as 'user' (something that I did for over two weeks) - strangely though evrything works fine again if I 'su' and log in as 'root'

    it's really driving me crazy - I tried to uninstall the 'gyach' package and reinstall it again as though it was first install .... nothing - now to chat on linux user' room on yahoo (by gyach) i have to 'su' and log in as 'root' and that bothers me cos i really dont know how dangerous that can be - to make things worse I can't just type 'gyach' as I used to, it just won't work - I have to go to the gyach directory with root privilege and then, maybe and hopefully, get on line

    I am almost to give up with it and delete the user account and logging in as root all the times but I know it's not safe - another options would be opening my door 'window' and throw my box outside as far as possible ...... so if any of you guys have some really good advice shout it out to me - plsssssssssss
    If you get on the wrong train all the stations you will come to will be the wrong stations.
    Zen

  10. #9
    Linux User
    Join Date
    Jul 2004
    Posts
    256
    Quote Originally Posted by operator
    sorry been very busy with fixing everything else on my box and now that everything seems to work fine I think I understood - the 'su' line works fine and in fact I get root privilege on console even if i'm logged in as 'user' - but still it won't let me open my partition on 'X' (graphical interface) and I came to the conclusion that perhaps it's a security feature of slack10
    If you start X as user "joe" all programs when you click icons, etc, are running as user "joe". If you open a term (ie: xterm) and su root, then you can run graphical programs as root if required, example
    Code:
    su root
    <enter pass>
    gvim /etc/fstab
    If you append an apersand "&" you run programs in the background,
    Code:
    $ gvim &
    If you dont run the program in the background, the terminal will wait untill the program exits, to let you continue.
    --monkey

  11. #10
    Linux Newbie
    Join Date
    Mar 2003
    Location
    Istanbul/Türkiye
    Posts
    246
    First of all operator you are right about the thoughts of X applications starting it with su. This is a Slackware special securtiy case. You can use
    Code:
    kdesu command
    for starting the applications. or if you got the root rights with su (not with su - ) you can start some (but some) X applications. But kdesu always work (altough sometimes it can crash).

    For the gyach problem, do the other users have the rights for starting it now?

    To learn this go to the directory where gyach in and make a

    Code:
    ls -l
    command. If the rights is not provided, do this with
    Code:
    chmod
    Just a Newbie....Looking 4 Info....

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •