Find the answer to your Linux question:
Results 1 to 6 of 6
I've installed slax6 onto an ext3 partition and setup a users account, i've also just managed to mount some virtualbox shared folders which are working and i can access them ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2009
    Posts
    53

    File Permissions Slax6


    I've installed slax6 onto an ext3 partition and setup a users account, i've also just managed to mount some virtualbox shared folders which are working and i can access them fine. The problem is I cannot seem to give limited user accounts access to them. root can access them no problem! but right clicking and changing the permissions do nothing, because once I click apply, reopen the menu, the changes have reverted.

    I've tried chmod'ing them.. chmod o=rwx /mnt/folder I used 'o' because I can't seem to change the group permission for the folder.

    The shared folder I am mounting is formatted in NTFS and the other in ext3, I can't change the permissions of either.

    Can someone shed some light on this please?

    Thanks!

  2. #2
    Just Joined!
    Join Date
    Dec 2009
    Posts
    53
    bump please.

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    You have to give ownership of ext3 mount point to Regular User.
    Code:
    chown -R user_id:group_id mount_point
    For NTFS partition, set umask=0 in mount command or /etc/fstab file.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2009
    Posts
    53
    Thanks!

    I tried remounting the ntfs share with the option you suggested but still the same issue.

    when they are not mounted; i can take ownership of the mount points, but as soon as i remount, they default back to owner:root group:root; and that includes the ext3 share mount point.



    these are the lines in my fstab

    Refills_Shared /mnt/Refills vboxsf rw umask=0 0 0
    Personal_Share /mnt/My_Share vboxsf rw 0 0


    Thank you.

  6. #5
    Just Joined!
    Join Date
    Dec 2009
    Posts
    53
    bump

  7. #6
    Just Joined!
    Join Date
    Dec 2009
    Posts
    53
    well as you guys can probably tell im a bit of a noob atm, so i did a bit of reading on mounting here .. tuxfiles[dot]org/linuxhelp/fstab.html

    turns out i need to mount the volume as a user as it defaults to root, to do that i needed to specify the owner uid and gid.

    the above lines should look like so..

    Code:
    Refills_Shared /mnt/Refills vboxsf rw,uid=1000,gid=100 0 0
    Personal_Share /mnt/My_Share vboxsf rw,uid=1000,gid=100 0 0

    if you are googling and come across this thread (like i was doing franticly) then you are probably a noob like me.

    open a shell and to find your group id and user id of the current shell session do..

    Code:
    id -g
    id -u
    Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •