Find the answer to your Linux question:
Results 1 to 10 of 10
Installed Slackware 10 Saturday afternoon. just to share my thoughts with the community. Installation was a breeze. It's quite refreshing to see how such a 'simple', non-gui style of installation ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User zba78's Avatar
    Join Date
    Feb 2004
    Location
    Birmingham, England
    Posts
    335

    First impressions of v10


    Installed Slackware 10 Saturday afternoon. just to share my thoughts with the community.

    Installation was a breeze. It's quite refreshing to see how such a 'simple', non-gui style of installation can still be so functionally efficient in this day n' age. Did a full install with no prompting for packages. Installed to hdb8 (hdb1 is swap, hdb6 is SuSE 9.1, hdb7 is /home for SuSE)

    Couldn't be bothered to setup network during setup so left that till after install (not sure why I did that). Selected KDE as default DE. Selected to mount the SuSE & Win partitions (on the first Hdd). Didn't bother to install Lilo as I intended to edit grub through SuSE to choose which distro to boot (which I successfully did after installation).

    So booted into Slack 10. Runlevel 3. Fire up mc. Edit Xorg.conf to set monitor frequency correctly for my 19” monitor. Add 1280x1024 as an available mode to the device section. Add the “5” buttons and “ZaxixMapping” details to mouse section. Also edit inittab to select Runlevel 4 as default.

    Do startx. WOW Kde loads fast. Never seen kde load that fast on SuSE. Monitor frequency is fine but resolution is 1024x768. Ctrl + Alt + + won’t allow me to select higher then 1024x768. So back to init 3. Install nvidia 1.0.6111 driver back into X and all is fine. 1280x1024@24 bits at 85-90Hz (need to try 32 bits colour).

    Run glxgears, 2300 fps. Strange because in SuSE 9.1 I get 3600 fps. Will have to work that one out later, it’s not a priority.

    Mouse pointer works fine but wheel just won’t work at all. Added “Emulate3Buttons” option to xorg.conf but still no joy. Again another thing for me to work out.

    Run netconfig, setup broadband, no problems. Run alsaconf, setup Soundblaster Live, no problems.

    After having to put up with the disgusting Keramik theme (not slackware’s fault but KDE’s, Why does such a great project use that as the default? ) head over to kde-look.org, download some windecos and themes. Compile, make and make install. WOW they ALL worked with no errors at all. That’s practically the first time I’ve experienced compiling source successfully. With SuSE I just gave up hope ever trying and always searched for an rpm.

    Downloaded k3b from linuxpackages and did installpkg. Installed almost in the blink of an eye. How was that possible?

    So using Slackware for 1 ½ days this is what I noticed so far:

    - Fast, very fast. KDE no longer seems bloated. Things just ‘run’ when you execute them. Haven’t even tried Xfce 4.0.5 (I used to use XFce on SuSE when I just wanted things done in a hurry)
    - Rock solid stable. I can’t crash this thing even if I try.
    - I get a real feeling that I’m learning/using ‘Linux’ as it should be. Gives a real feeling of accomplishment. I’ve been running SuSE as my main OS for nearly a year now (first 8.2 then 9.1)
    - So configurable. I get the feeling of no boundaries, no limits.
    - Compiling from source ALWAYS works. It’s quite amazing.

    I’m enjoying it all so much. Yes many things have to be done manually, but I’m learning so much in the process. And I have a better understanding of my OS.

    Slackware just seems awesome. Still got a lot to setup and configure. Downloaded OOo 1.1.3 but haven’t installed it yet. Still got to install my printer etc. etc.

    So far I am very impressed. Stable, fast and responsive. What more could a person want from an OS? I’m sure I’ll be asking for help around these forums in the future (maybe about the mouse wheel but for now I’ll happily play about the settings and get it all going bit-by-bit.

    One quick question, does Slack 10 come with a firewall application?
    Ubuntu Jaunty :: Arch Linux (current) :: Acer Aspire 1692WMLi

  2. #2
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    That is exactly why I switched to slackware from SuSE a couple more weeks and you will be deleting SuSe for more disk space. Wait till you run OOo... You will really be amazed at how fast it starts compared to SuZE. I am running Slack 10 on a P4 1.6 and OOo starts at a blink of an eye.

    I am glad to see you like it. Keep working on that mouse thing you will figure it out. Go back a few posts I know I have posted my xorg.conf file and so have a lot of other people maybe you will see that one thing you are missing.

    Good Luck
    Mike

  3. #3
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    I have had only one none-good experience with slack so far...all of the benefits you mentioned are good, really good; KDE still locks up for me on initializing peripherals! Thats the only problem though, however, its a rather large one because it prohibits my use of the mouse and my network...boot into a knoppix, use internet, boot back into slack...takes alot of time

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2004
    Posts
    2
    today i install slackware 10.0 but i could find to compile or install a boot loader like grub or lilo what you recomend me ?

  6. #5
    Just Joined!
    Join Date
    Sep 2004
    Location
    Bucharest, Romania
    Posts
    7

    Mouse wheel in Slackware 10

    You have to configure correctly the gpm daemon with your right mouse type (usb,ps2,serial) and port.
    Next in /etc/X11/xorg.conf you set the Device /dev/mouse
    The type is IMPS/2 for ps2 & usb mice and IntelliMouse for serial ones.
    And there's one thing to add to the Mouse section:

    Option "ZAxisMapping" "4 5"

    And then just press CTRL+ALT+BACKSPACE to kill the X

    Good luck !

  7. #6
    Linux Newbie
    Join Date
    Mar 2003
    Location
    Istanbul/Türkiye
    Posts
    246
    I think just adding Option "ZAxisMapping" "4 5" is not enough. Also add
    Option "Protocol" "Auto" under mouse section to your /etc/X11/xorg.conf file.
    Just a Newbie....Looking 4 Info....

  8. #7
    Linux User zba78's Avatar
    Join Date
    Feb 2004
    Location
    Birmingham, England
    Posts
    335
    I just added "protocol" "IMPS/2" and the wheel works fine now
    Ubuntu Jaunty :: Arch Linux (current) :: Acer Aspire 1692WMLi

  9. #8
    Linux Newbie
    Join Date
    Mar 2003
    Location
    Istanbul/Türkiye
    Posts
    246
    Smiliar way, instead of IMPS/2 you can use Auto. The critical thing is adding "ZAxisMapping" "4 5" is not enough.
    Just a Newbie....Looking 4 Info....

  10. #9
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    What does the protocal "auto" do exactly?

  11. #10
    Linux Newbie
    Join Date
    Mar 2003
    Location
    Istanbul/Türkiye
    Posts
    246
    I think it is detecting the type automatically
    Just a Newbie....Looking 4 Info....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •