Find the answer to your Linux question:
Results 1 to 6 of 6
I've seen that firefox is the only program that wont show the buttons and the scroll bar like the oxygen ones.. i was going to post a picture but i ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2010
    Posts
    10

    Firefox no oxygen style?


    I've seen that firefox is the only program that wont show the buttons and the scroll bar like the oxygen ones..
    i was going to post a picture but i only have like 3 posts
    anyone with the same issue?

    Thanks in advance
    my OS: Slackware 13

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,132
    Firefox uses GTK as its toolkit. To get around this you can either install a standalone Firefox Oxygen theme or you can set your GTK theme to use Oxygen, either as a standalone them or by using one of the tools for mirroring KDE's theme.

    I know I'm being a bit vague but I'm coming from the otherside. I run a Gnome desktop so as I install my KDE apps such as Amarok and Ktorrent, I install KDE4 systemsettings and set the theme to point at GTK's theme and then manually synchronise the colours. That way no matter what application I open up they all look native

  3. #3
    Just Joined!
    Join Date
    Mar 2010
    Posts
    10
    Quote Originally Posted by bigtomrodney View Post
    Firefox uses GTK as its toolkit. To get around this you can either install a standalone Firefox Oxygen theme or you can set your GTK theme to use Oxygen, either as a standalone them or by using one of the tools for mirroring KDE's theme.

    I know I'm being a bit vague but I'm coming from the otherside. I run a Gnome desktop so as I install my KDE apps such as Amarok and Ktorrent, I install KDE4 systemsettings and set the theme to point at GTK's theme and then manually synchronise the colours. That way no matter what application I open up they all look native
    i messed up everything i tried setting GTK+ as my main style X quitted and now i cant go back
    im using root account to post here

  4. #4
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    Quote Originally Posted by iavor
    i messed up everything i tried setting GTK+ as my main style X quitted and now i cant go back
    im using root account to post here
    Au! I had that happen to me too.

    The fastest way around this is from textual mode
    Code:
    mv ~/.kde ~/kde.bak
    and log back in. This builds a new profile. The old one is now in ~/kde.bak, so you can restore it or parts of it if you need. Otherwise you can throw it away.
    Can't tell an OS by it's GUI

  5. #5
    Just Joined!
    Join Date
    Mar 2010
    Posts
    10
    Quote Originally Posted by Freston View Post
    Au! I had that happen to me too.

    The fastest way around this is from textual mode
    Code:
    mv ~/.kde ~/kde.bak
    and log back in. This builds a new profile. The old one is now in ~/kde.bak, so you can restore it or parts of it if you need. Otherwise you can throw it away.
    thanks man ill keep that in mind for next time..
    i kind of reformated

  6. #6
    Just Joined!
    Join Date
    Oct 2008
    Location
    CANADA
    Posts
    4
    Hey did you try to get gtk-kde4.

    go to SlackBuild.org and search it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •