Find the answer to your Linux question:
Results 1 to 7 of 7
Hello everybody, I'm using: slax distro KDE v. 3.5.2 Linux 2.6.20 When I select a screensaver in the control center and click on the "test" button, nothing occurs. It is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2010
    Posts
    9

    screensaver not starting [kde 3.5.2 - kernel 2.6.20]


    Hello everybody,

    I'm using:

    slax distro
    KDE v. 3.5.2
    Linux 2.6.20

    When I select a screensaver in the control center and click on the "test" button, nothing occurs. It is the same with "Setup" button.

    I tried to start the screensaver with a shell command and it is the same.

    Someone has an idea? The screensaver should it be disabled somewhere?

    I'm a begginer... Thank you a lot for your help.

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    MAke sure you have the correct video drivers installed and if these are OpenGL screensavers, you need to make sure you have OpenGL installed.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Just Joined!
    Join Date
    Mar 2010
    Posts
    9
    No, OpenGL doesn't seems to be installed
    Code:
    bash: glxinfo: command not found
    Is it neccessary to install it? I only want to have a "Blank Screen" when the screen saver is activated.

    I'm using an Advantech PCM-9375 board (output TFT LCD).

    It is very strange: When the screen saver should be started (for example after 1 minute), the display dosen't change, but the mouse cursor is hidden. And after that, when I move the mouse, it is like when a display is wake up. The sleep mode seems to work well but without a screen saver.

  4. #4
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    It can't hurt to try installing OpenGL. Give it a shot.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  5. #5
    Just Joined!
    Join Date
    Mar 2010
    Posts
    9
    OpenGL is installed, problem still the same.

    glxinfo:
    Code:
    name of display: :0.0
    display: :0  screen: 0
    direct rendering: No
    server glx vendor string: SGI
    server glx version string: 1.2
    server glx extensions:
    ...

  6. #6
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Try installing a different screen saver package from your repos, just to see if they work or not.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  7. #7
    Just Joined!
    Join Date
    Mar 2010
    Posts
    9
    It works!

    Sorry to answer so late. But it was difficult to install a new screen saver.

    I'm using Slax 5 and I was installing a module *.lzm (for slax 6) and it wasn't compatible (compression error). So I have installed a *.mo module and move it on the slax/modules folder. But it wasn't automatically started after a restart... so finally I have installed the module graphically (double clic).

    After that a lot of new screensavers has been add on the "Configure desktop / Screen Saver" and if I select one of this new screen saver it works!

    But the "Blank screen" and "Random" still don't work...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •