Find the answer to your Linux question:
Results 1 to 9 of 9
Hey, I am having problems initializing KDE when I boot with hotplug enabled. When I boot with the command prompt "linux nohotplug" the system initializes fine, however without this after ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366

    Need help with hotplug support in Slack


    Hey, I am having problems initializing KDE when I boot with hotplug enabled. When I boot with the command prompt "linux nohotplug" the system initializes fine, however without this after I startx during the kde intialization screen at the initializing peripheral step the comp locks up and I have to manually restart. This causes me great problems because I really need hotplugging for my ethernet card to work.

    It works perfectly with live cds, dsl and slax,

    Can someone please give me an idea of how to fix this problem,

    Thank you so much for your time

  2. #2
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    Also, for testing purposes, does anyone know how to start hotplugging support once in kde?

  3. #3
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    I wish I could be more help, but I have the exact same problem as you. Heres what I do. I just disable hotplug and manually add my eth card when booting. this is a pain for me too because it is a laptop. I actually have some scripts that I wrote to do this for me though. I have scripst like ./home.
    Essentially this runs ifconfig eth0 up | cd /etc/rc.d | cp rc.inet1.conf. home rc.inet1.conf | ./rc.inet1

    this will pop my network up for my home network. I know it is not the right way of doing this but it works. I am interested too to see if someone can answer your question.

    Mike

  4. #4
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    I just got help on this problem in another forum...basically the answer was to manually start hotplugging once you startx...not that much of a pain and it worked wonderfully

  5. #5
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    So what your saying is turn off hotplug and manually turn it on after boot up then turn it off when going down?
    If this is true and you turn hotplug on, it then finds your eth card and works automatically?

  6. #6
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    Yeah, at the boot prompt, I just "linux nohotplug", then when I log in I "startx", then I open a terminal and su - and run the command: /etc/rc.d/rc.hotplug start ...after that my eth works perfectly, along with the rest of my hotplug devices...

    cheers, hope it works for you!

    Not sure if you have to turn it off when you go down though...still up! Tell me if you encounter any problems with it

  7. #7
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    I will try it, Stay tuned.

  8. #8
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    Didn't work for me, but starting and stopping hotplug isn't much different than running shell scripts when I start my system at different locations. It is a pain but not enough to switch distros. Plus I think I can probably fix it with a kernel recompile later when I am not so busy. Thanks for the advice though.

  9. #9
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    no problem man, at least we both have it working

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •