Find the answer to your Linux question:
Results 1 to 6 of 6
Hi .. I'm using slackware13. I love the simplicity. Recently I changed my window manager from KDE4 to Blackboxwm. Love the desktop as it is clear & simple. But there's ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2010
    Posts
    2

    Question Mounting USB in Slackware 13


    Hi .. I'm using slackware13. I love the simplicity. Recently I changed my window manager from KDE4 to Blackboxwm. Love the desktop as it is clear & simple. But there's a problem. When I plugin a usb thumbdrive or any external HD it does not detects automatically? Can someone guide me how to use a usb device(s) in a Blackbox environment? Thanks.

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Do you want it to automount usb drives, or do you want it to just show up with an option to mount?

    If you have the HAL daemon and D-Bus running, any D-Bus aware file manager should usually show up with an entry for the drive, which you can click to mount. What file manager are you using?

    To manually mount a drive, you need to make a mount point, for example
    Code:
    su -c 'mkdir /mnt/USB'
    And then use the mount command
    Code:
    su -c 'mount -t vfat /dev/sdb1 /mnt/USB'
    /dev/sdb1 is just an example. You can use the output of
    Code:
    su -c 'fdisk -l'
    to find the correct /dev node for your USB stick.

    If you use the XFCE file manager Thunar, it can handle automounting, if you install its volume manager, thunar-volman.

    There is also a lightweight standalone volume manager, called skvm. I don't know if there is a slackbuild for it, so you'll probably have to write one or just build it from source.

  3. #3
    Just Joined!
    Join Date
    Apr 2010
    Posts
    2
    Hi .. thanks for the info & sorry for the late response. I've just installed BalckBox in Slack13. Not yet installed any file manager to go with it. Can you show me both ways, how to automount usb drive & how just to show it up with an optyion to automount?

  4. #4
    Just Joined!
    Join Date
    Jul 2010
    Location
    Michigan
    Posts
    47
    I am also having trouble mounting my USB flash drive. You said, "If you have the HAL daemon and D-Bus running, any D-Bus aware file manager should usually show up with an entry for the drive, which you can click to mount.
    The USB drive does show up in dolphin file manager, but when I click on it, I get an error message: An error occurred whicle accessing "KINGSTON', the system responded: org.freedesktop.DBus. Error. Access denied: Rejected send message, matched rules; type="method_call", sender=":1.28" (uid=500 pid=6376 comm="usr/bin/dolphin -icon system -file-manager -captio") interface=org.freedesktop.Hal.Device. Volume "member="Mount" error name="(unset)" requested_reply=0 destination="org.freedesktop.Hal" (uid=0 pid=3021 comm="use/sbin/hald --daemon=yes"))
    Okay, what does that mean? I'm using Slackware 13.0. I get that it's not automounting, but why not?
    I tried mounting the USB stick and got the message: sandy@darkstar:~$ su
    Password:
    root@darkstar:/home/sandy# mount -t vfat /dev/sda /mnt/USB
    mount: wrong fs type, bad option, bad superblock on /dev/sda,
    missing codepage or helper program, or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so
    What do I do now? This USB drive works fine on other computers.

    root@darkstar:/home/sandy#

  5. #5
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    It's best to start a new thread for your question rather than tail on an old one.

    A couple of things to look at. 1. Are you in the plugdev group? 2. Open the file /etc/dbus-1/system.d/hal.conf for lines like
    Code:
    <policy group="plugdev">
    <allow send_interface="org.freedesktop.Hal.Device.Volume"/>
    <allow send_interface="org.freedesktop.Hal.Device.Volume.Crypto"/>
    </policy>
    Add them if they are not there. Note you'll need to be root to edit the file and you'll need to restart the HAL and Dbus daemons after the changes. (Or just restart the computer.)

  6. #6
    Just Joined!
    Join Date
    Jul 2010
    Location
    Michigan
    Posts
    47
    reed9,
    I finally got the USB drive mounted and I can read it. I checked the /etc/dbus-1/system.d/hal.conf file as you suggested, and everything was there as it should be.
    I used this info:To manually mount a drive, you need to make a mount point, for example
    Code:

    su -c 'mkdir /mnt/USB'

    And then use the mount command
    Code:

    su -c 'mount -t vfat /dev/sdb1 /mnt/USB'

    /dev/sdb1 is just an example. You can use the output of
    Code:

    su -c 'fdisk -l'

    to find the correct /dev node for your USB stick.
    >> to figure out how to get a flash drive located and mounted properly. I want to thank you for that info. Without it, I'd still be sitting here wondering.
    I suspect there's an issue with the first flash drive I tried to mount. I think it meeds to be reformatted. In console, when I tried to mount that flash drive, I got the printout:
    wrong fs type, bad option, bad superblock on /dev/sda, missisng codepage or helper program, or other error. In some cases useful info is found in syslog - try dmesg | tail or so
    I did dmesg | tail, and after the scan it said:
    sd 2:0:0:0: Attached scsi generic sg0 type 0
    FAT: Invalid media value (0 x b9)
    VFS: Can't find a valid FAT filesystem on dev sda.

    So, mounting USB drive is solved for me. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •