Find the answer to your Linux question:
Results 1 to 2 of 2
After finally getting libptp2 to compile I find that ptpcam does not work. This has worked perfectly fine before with the same camera using Slackware 12.0, I am now using ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Jul 2007
    Posts
    111

    Unable to make ptpcam working


    After finally getting libptp2 to compile I find that ptpcam does not work.

    This has worked perfectly fine before with the same camera using Slackware 12.0, I am now using Slackware 13.1 and ptpcam will simply not work.

    The error is as follows:

    Code:
    x86_1# ptpcam -l
    
    Listing devices...
    bus/dev vendorID/prodID device model
    ERROR: Could not open session!
    Try to reset the camera.
    I have tried to reset with "ptpcam -r", I have also tried to disconnect and reconnect the camera to the USB system, I have tried to reboot the computer, I have tried to use different versions of libptp2 -- all to no avail.

    The strace shows the issue is apparently a failed ioctl(), although I have no idea why it fails:

    Code:
    open("/dev/bus/usb/002/004", O_RDWR)    = 6
    write(4, "\1"..., 1)                    = 1
    read(3, "\1"..., 1)                     = 1
    ioctl(6, USBDEVFS_SETCONFIGURATION, 0xbff18044) = 0
    ioctl(6, USBDEVFS_CLAIMINTERFACE, 0xbff18014) = 0
    ioctl(134577232, UI_DEV_DESTROY or USBDEVFS_BULK, 0xbff17f90) = -1 EBADF (Bad file descriptor)
    write(2, "ERROR: Could not open session!\nTr"..., 56ERROR: Could not open session!
    Try to reset the camera.
    ) = 56
    ioctl(6, USBDEVFS_RELEASEINTERFACE, 0xbff18044) = 0
    write(1, "\n"..., 1
    )                    = 1
    exit_group(0)                           = ?
    I have verified that the camera is working in Windows 7 on the same physical computer and I can see the camera from lsusb and dmesg output when I connect it to the USB system.

    This system is Slackware 13.1, Linux x86_1 2.6.33.4-smp #2 SMP Wed May 12 22:47:36 CDT 2010 i686 Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz GenuineIntel GNU/Linux.

  2. #2
    Linux User
    Join Date
    Mar 2008
    Posts
    287

    Unable to make ptpcam working

    While trying to get mplayer to work with my web cam I had similar errors after I would get it working.
    Try this:
    Disconnect cam and cold boot.
    Run cat /proc/asound/cards and
    ls /dev/au* /dev/ds* /dev/vi*
    Connect cam and repeat.
    Shutdown and reboot leaving cam connected
    Repeat commands above.
    It may be that the cards are being changed around. My cam went from card 2 to card 0. That is mystifying when it happens. Hope this solves it 4 U

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •