Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, my machine has windows and slackware 13.1 installed. While starting slackware i mount the win D drive (using an entry in fstab).Recently i ran an updatedb but I cannot ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2010
    Posts
    7

    updatedb not indexing files on ntfs drive


    Hi,
    my machine has windows and slackware 13.1 installed. While starting slackware i mount the win D drive (using an entry in fstab).Recently i ran an updatedb but I cannot locate any file on the ntfs drives though they were mounted when i ran this command. Only file on my ext3 partition are located. Can anyone suggest a way out?

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    What is the mountpoint for your ntfs filesystem?

    If you look in /etc/updatedb.conf, there is a list of paths which are excluded from indexing. If your mountpoint is in /media or /mnt for example, it probably won't be indexed by default.

    My updatedb.conf for example is
    Code:
    # directories to exclude from the slocate database:
    PRUNEPATHS="/media /mnt /tmp /var/tmp /var/cache /var/lock /var/run /var/spool"
    
    # filesystems to exclude from the slocate database:
    PRUNEFS="afs auto autofs binfmt_misc cifs coda configfs cramfs debugfs devpts ftpfs iso9660 mqueue ncpfs nfs nfs4 proc ramfs securityfs shfs smbfs sshfs sysfs tmpfs udf usbfs"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •